Broken FrSky Telemetry on SPort/X8R?

Hey there,

I have problems getting proper FrSky telemetry values on my Taranis using a X8R Receiver.
The only values that seem to work fine are VFAS and Fuel.
Especially Hdg (always at 0.00°) and GPS coordinates/dates (random values) seem broken. I also would like to have the current flight mode in Tmp2 or so, like the Teensy Mavlink converter offers.
Why using an additional converter when there’s build-in telemetry support?

I tried deleting all sensors and rediscovering them without success.
Can anyone confirm that FrSky telemetry for SPort receivers isn’t broken in the master build? Or am I missing something, like the telemetry output isn’t Taranis compatible?

My setup:
Master firmware of 2016-05-21T14:07:14.000Z for FMUv2
Taranis Plus with OpenTX 2.1.8
X8R connected with self-made TTL-RS232-converter with diode on Serial 2
SYS_COMPANION set to FrSky Telemetry

Thank you for your input!

Kind regards,

I think may have broken FrSky compatibility in favor of a Lua script.

I have made some changes in this PR to better support LUA scripts (which offset the nav_state by 128 in Tmp2), but since that got merged, a big new change in the way openTx handels custom telemetry values has happened (custom DIY values, that can be parsed by lua scripts - like PixPilot - and thus there has been a rewrite in this new PR here to support the new DIY ids:

As you see, some values like the heading and the GPS data are still not yet correctly sent, as I still need to reverse engineer how the taranis decodes the values. I’m traveling, but once I’m home I’ll have the chance to correct and verify the way gps values (especially date and time) are sent. Please try my changes in the latest PR mentioned above and let me know if you have any inconsistencies in the telemetry data :slight_smile:

If you want, you can even hop over to the PR and help me further reverse engineer the way opentx decodes the data:

1 Like

In case it helps, GPS lat/lon was displaying properly on my OpenTX 2.1 Taranis before your changes went in.

Hey Leon & Mark,

thanks for your answers!
Sadly, currently I don’t have enough time to create an environment to compile PX4 myself and test code. Maybe in a few days.
In the past I created a converter for the Walkera X350 Pro (, so I have some experience in telemetry stuff.

I’d like to flash new test builds to support you!

Instead of reverse engineering the OpenTX receiving library, maybe we should look at this library:

EDIT: This one uses the new telemetry IDs like in the PX4 telemetry module:

And this is the LUA script I’m currently using:
Maybe there are better ones.

Kind regards

Sweet, thanks for mentioning the library, that should make things a lot easier :slight_smile:
I’ll probably have a bit more time to look at it tomorrow (I’m quite busy with and I should probably study for uni…)

Actually, if you haven’t seen it yet, I’m also working on a lua library/collection named PixPilot! Have a look at the (still a bit lean) Documentation!

Yeah, I saw your library, and really would like to use it. But I prefer using a stable OpenTX.
What is the reason behind having OpenTX 2.2 as a requirement?

This PR which implements new DIY ids, which I use in my new PR to send the data we want, instead of misusing e.g. the Tmp1 and Tmp2 values. It allows us to send up to 512 more data values :slight_smile:


I want to rewrite the FrSky telemetry with the IDs using two bytes by myself.

After trying to set up the px4 Toolchain under windows and failing, I set up an Ubuntu VM.
Followed all the Toolchain Installation for Linux but can’t get the compilation to work:

/home/simon/src/Firmware/src/include/…/platforms/px4_subscriber.h:42:22: fatal error: functional: No such file or directory

arm-none-eabi-gcc --version

arm-none-eabi-gcc (15:4.9.3+svn227297-1) 4.9.3 20150529 (prerelease)
Copyright © 2014 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO

Maybe someone help me to set up the toolchain correctly?

Kind regards

Try following the instructions here to install a supported version of GCC.

Thanks Mark,

this is what I already tried.
Although I installed the 4.8 version, it always uses the 4.9.3 version.
Maybe you can give me a hint to remove the old version?

is there a solution to this already?

It’s now June 2017 and I still get this telemetry issue…

I’m running OpenTX 2.2 and GPS, DATE and other telemetry information on the my Taranis radio are still mangled.

Hardware setup is a Pixracer FC and X8r frsky TX connected to sport

Help please.