OSD says "Waiting for MAVLink Heartbeats" when attached to TELEM 2 port

My OSD works when attached to TELEM 1. When I attach it to TELEM 2 and set the MAVLink parameters to the same as TELEM 1, it just says “waiting for MAVLink heartbeats” on the OSD.

The Parameters I have set are:
MAV_1_RATE = 57600 B/s

These are all the same settings I have for MAV_0 instance, except MAV_0_CONFIG = TELEM 1.

Does anyone know why the OSD will only work in TELEM 1?

I am using Pixhawk 6C mini with PX4 1.13.3

I think you have mixed up the param RATE for baudrate. The rate needs to be max 1/10 of the baudrate. And the baudrate needs to be set using SER_TEL2_BAUD (or something similar).

1 Like

Hi @JulianOes
Thanks for your reply.
I have set the parameters as you said and that unfortunately hasn’t worked.

Attached are screenshots of my parameters page on QGroundControl.

I set SER_TEL2_BAUD to 57600 and the MAV_1_RATE to 1/10 of that (5700). The OSD still says “Waiting for MavLink Heartbeats” when plugged into TELEM 2.

It works fine in TELEM 1 and the MAV_0_RATE and SER_TEL1_BAUD are both set to 57600. (Although I cant get flight mode to display)



Try disabling flow control.

Thank you that solved it. :pray: