Only 2 motors spinning problem

Hi,

I have a diy quad using the pixhawk. I’m using the latest stable qgroundcontrol and flashed in the latest firmware. Configured as generic x quad.

After arming, only motors 3 and 4 spin, an the other 2 are not, even after raising the throttle. When I physically tilt the quad to add some roll/pitch, one of motors 1 or 2 starts to spin to compensate for that. This behavior also seems to be dependent on the current yaw of the quad.

I did calibrate the ESCs and also verified that motors/ESCs/power distribution is working by connecting the rc receiver straight to the ESCs. I also tried to raise the min pwm and min idle throttle params which did not help. Raising the min idle throttle increases the speed of the 2 motors already running, but not run the other 2 motors.

Sometimes, after fiddling around with the control sticks of my rc transmitter for some time, all 4 motors start to spin and I was able to fly it. But every time at the instant i arm it, only 2 motors spin and can’t take off properly.

Any ideas whats wrong?

Thanks
Enyu

You need to raise the PWM_MIN parameter or calibrate your ESCs in order to bring their range in sync with what the system is using.

ok that worked! thanks! I thought I tried that before but maybe I did something wrong previously.

Hi Lorenze,

I’m having the same problem with a generic 450 quad with a Pixhawk and PX4 1.4.1. It flies with arducopter. I’ve changed PWM_MIN from 900 to 1400. I get the same results. Only two motors will spin. Any ideas?

Thanks!

Brian

1400 is a pretty big value, to any kind of ESC & motor.

So looks something wrong with the ESC or motors if even 1400 can not drive them spin.

Hello everyone.

I have same issue with my DIY drone. When I armed, there is no problem, all motors spin with my PWM_MIN value (1100). But if I give max throttle; 2 motors are spinning slowly and stopping, 2 motors are spin higher. What should I do?

Thanks!