Unstable Motors output - Cube Orange Hexarotor x

Hi, I’m the beginner in the PX4.
I use QGC Daily Version master:d31b58f3f 2022-04-22 06:01:09 +0000 to flash firmware PX4 Pro Stable v1.12.3 to my Cube Orange.
I use my custom structure frame, 6xTmotor MN601-S KV170 with FOC ESC Alpha 60A HV 12S, Cube Orange with Here3, Skydroid H12 and 2x6S Battery 16000mAh.

I set the position of sensors like this >
EKF2_GPS_POS_Y = -0.205 m (205 mm from CG)
EKF2_GPS_POS_Z = -0.190 m (190 mm from CG)
EKF2_IMU_POS_Z = -0.15 m (150 mm from CG)

Calibrate all sensors and radio.
SYS_AUTOSTART = 6001 (hexarotor x)
PWM_MAIN_MIN = 1075 us

Motors test and motor ordering is normal.
I confuse the PWM_MAIN_OUT of this airframe default setting because it’s 12345678 but I think it should be 123456.

I armed in stabilized mode without props and tilt drone 60 degree, then some motors stop and some motor resumed spinning after the drone was placed. So I cannot find the solution to deal with it.
(the method that i test from Redirecting to latest version of document (main))

So I decide to test with props on the ground as the videos and log files.


I want to ask some question for the confirmation. Is the FOC ESC need to ESC PWM calibration in the QGC? (in the picture)

Please help how to fix this problem. Thank you for the attention.

1 Like

I had the same problem until I calibrated ESCs, so I think you should try that. Also, you might have to set the minimum PWM value higher.

Thank you pacak.

I don’t sure about the calibration ESCs, because the provider said “FOC ESCs no need to calibrate”.
Could you confirm the FOC ESCs need to calibration?
I use T-motor MN601-S 170KV and ALPHA 60A HV 12S built-in the base of motors.

Should to test PWM_MAIN_MIN more than 1075 us, right?
and PWM_MAIN_OUT is 12345678 is correct? it looks weird.

Can’t confirm that, I don’t use the same ESCs.
I know I calibrated different ESCs according to manufacturers notes, and then calibrated them again in QGroundControl.

I can’t tell what you should look for multicopter frame, but for VTOL the parameter is VT_IDLE_PWM_MC; so what PWM it should output after arming and while it’s horizontal.

1 Like

Can’t fix it. I set PWM_MAIN_MIN to 1100 or calibrated the ESCs(with Power setting in QGC) but the result as the same as some motors stop in the Manual/Stabilize mode.

= Armed → Thrt20-30% → Some motors stop. → something Thrt or Tilt Roll and Pitch → The dead motors spin but another motors stop
(always there’re 2 motors that stop or spin very low RPM at the same time)

In Altitude or Position mode if I armed and release the throttle to the center the motors don’t start spinning then disarmed by the systems.

= Armed → Thrt50% → All motors do not spin

But if after arming(Altitude or Position Mode) and push up the throttle about 60-70% the motors starting to spin, then I must to lower the throttle to 20-30% to let it stay on the ground. Then some motors stop spinning after 20-30% about 10 seconds but if I quickly to takeoff it after 20-30% the hexarotor can fly normally.

= Armed → Thrt70% → Motors spin from 0 to fast → Thrt20-30% for 10 sec → Some motors stop
= Armed → Thrt70% → Motors spin from 0 to fast → Thrt30% → Thrt up and control it to smooth takeoff → Fly normally.

I was test with my Quadrotor with not FOC ESCs it fly normally.
Please help.
What’s my mistake of this symptom?

In my case can fixed the hexarotor problem by set the PWM_MAIN_MIN = 1180 us (for this motor combo)
I think the FOC ESCs no need to calibrations as the provider said.
log file : https://review.px4.io/plot_app?log=5d63cd99-a1cd-4c36-a937-265a53389c5f

hello,Up,which PCU are you choose?