Vehicle arms but motors dont spin

Hi.

I am using a pixhawk mRo 2.4.8 and just updated the firmware from 1.13.0 to 1.14.0.

After doing this, I selected the airframe, calibrated the sensors and ESC. However when going to Identify and Assign Motors in Actuators, it happens that the motors dont spin, but it let me select which motor “is spining”. Therefore it allows me to complete the assignment of motors.

Then, I am able to arm the drone, however the motors still dont move. The battery is properly connected, and motors where working before the firmware update but not afterwards (which is a timelapse of 15 min) , so I dont believe it is a hardware problem.

Another strange thing , that might or might not be related, is that when I go to MavLink Console and write the command dmesg, I recieve the message:

nsh: sysinit: fopen failed no such file or directory

no output, and the console glitches and doesnt allow me to write any other command.

Thanks in advance!

Update: I was playing with the PWM disarmed values in the actuator page, and it results that the motors start to spin at a value of 1800. I also tried lifting the throttle up after arming, and motors start to spin.

Therefore I should set the minimum pwm at 1800. However, the range for the parameter PWM_MIN for all motors is 800-1400. Is there any way to bypass this limitation?

Also, I remember that in px4 v1.13 I used to set pwm_min_main at 1000 and it worked perfectly. Did the firmware update changed how the pwm_min parameter works?

Thanks!

This is very typical bug found while updating to v1.14. I thought this was corrected.
I faced a near similar issue with Cube Orange Pixhawk version where the ccw and cw motors reversed…!! I had to rewire all the motors …