Nsh>micrortps_client: command not found issue

When I try to connect my flight controller via UART in nsh terminal I got the error like:
micrortps_client: command not found

I wote the terminal before it
then it works, I thought I need to upload it then I tried but it gave me the message like:

~/PX4-Autopilot$ make holybro_durandal-v1_rtps upload
[0/16] Performing build step for ‘px4io_firmware’
ninja: no work to do.
[1/5] Performing build step for ‘bootloader_firmware’
ninja: no work to do.
[4/5] uploading px4
Loaded firmware for board id: 139,0 size: 1809153 bytes (92.02%), waiting for the bootloader…

Attempting reboot on /dev/serial/by-id/usb-Holybro_PX4_DurandalV1_0-if00 with baudrate=57600…
If the board does not respond, unplug and re-plug the USB connector.

And nothing happened, just continue giving me the message and I replug my controller same issue happened.What can I do?

Hi @tugbakara,
I also faced similar issues with the px_uploader python script.
Instead of unplug and plug let it timeout and try again the same command. That usually works for me.

./px_uploader.py …/build/holybro_durandal-v1_rtps/holybro_durandal-v1_rtps.px4 --port /dev/ttyACM0

I tried it also but it is uploading the firmware not the rtps so I am still searching the solution… When I am in the nsh terminal then I write the micrortps_client nsh give me this message: micrortps_client COMMAND NOT FOUND.

Im sorry but I dont follow you. Do you mean you cant compile with rtps? Upload?

I couldn’t upload when I tried give me the message written in my topic, first one.

Does it reach timeout?

I solved it but now I got another problem… I think it never end.