(Closed)Couldn't upload firmware to px4

#1

Hi, all.

I try to upload firmware to px4 connected by USB.
Use this command from guide.
make px4fmu-v5_default upload

After compiling i got this line and nothing happened?

ninja: Entering directory `/home/…/Firmware/build/nuttx_px4fmu-v5_default’
[0/1] uploading px4
Loaded firmware for board id: 50,0 size: 1589689 bytes (77.01%), waiting for the bootloader…

I waited about 1 hour. Nothing happend.

My current system is pure Ubuntu 18.04 LTS. Also i tried same on VMbox under Win10 with same Ubuntu distributive and got same line.

I know that my px4 works. My drone flight. I uploaded firmware by QGCS and Mission planner. All worked fine.
What’s wrong? i couldn’t find any topics about this.

#2
  1. Did you try powering the Pixhawk off completely and then plugging in the usb?
  2. I assume you are using a Pixhawk 4 from Holybro?
  3. The other option would be that there is no bootloader on the board in which case you need to flash it.
    You can follow these instructions https://dev.px4.io/en/software_update/stm32_bootloader.html
#3

Also:

  • have you tried another usb cable and a different usb port?
  • does the Pixhawk work in the current state? If yes, that would indicate that there is a bootloader and it should work?
#4
  1. Thanks. It seems i tried.
    Now after this acttion plug off and plug in i get this message.

Found board id: 9,0 bootloader version: 5 on /dev/serial/by-id/usb-3D_Robotics_PX4_BL_FMU_v3.x_0-if00
WARNING: Firmware not suitable for this board (board_type=9 board_id=50)

  1. No. It isn’t possible to by in Russia. I couldn’t find shop with delivery to Russia and be sure it isn’t a clone.
    I by my APM at Aliexpress CUAV official store.

  2. I’ll try this option if no way)))

#5
  1. I try both on PC with pure Ubuntu and 2 laptops with VMbox Ubuntu
  2. Yes. It work fine. I could connect it by Mission Planner on qGCS both. And could flash firmware in this apps.
#6

After trying this command make px4fmu-v3_default upload it isuploaded

Found board id: 9,0 bootloader version: 5 on /dev/serial/by-id/usb-3D_Robotics_PX4_BL_FMU_v3.x_0-if00
sn: 002700373337510b39353636
chip: 20016419
family: STM32F42x
revision: 3
flash: 2080768 bytes
Windowed mode:False

Erase : [====================] 100.0%
Program: [====================] 100.0%
Verify : [====================] 100.0%
Rebooting. Elapsed Time 22.001

But i couldn’t understand which pixhawk i have? PX4?

#7

Hi

I had the same issue with the bootloader taking ages and doing nothing. I changed my USB cable twice substituting it for a new one bought in store. Pulling the USB out and plugging it in mid boot only caused further chaos. I also looked at uploading a new bootloader but luckily realised that the version control seems to be my issue. I changed the version from v4 to v3 and got a memory warning from the compiler. I then changed to v2 and with luck was able to boot the program using this line:

make px4_fmu-v2 upload.

Hope this helps.