Hi! I don’t know what to do anymore! I really need help!

I have:

  1. Pixhawk 6x (latest stable firmware from PX4)
  2. Multiple laptops (Mac, Windows10, Ubuntu 22.04)


  • type-C is no longer detected automatically,
  • via ETHERNET also does not determine (and QGC didn’t define it before either, but mavsdk_server saw my Pix6),
  • via Telnet (L: admin, P: Administrator) I can access the Pix6 file system from Ubuntu22, + there is a “mavlink” in the built-in commands of Pix6…I even tried to use it (this command works), but it was not possible to establish a connection!

On a laptop with Windows10, I installed mission planner(MP) and I was able to connect my Pix6 via COM-port, but I can’t change any settings + I flashed it to Ardupilot and QGC also started to see it and detect Pix6 automatically

And all this happened because I was playing with the settings in Pix6… I tried to change UDP ports, changed operating modes (MAV_2_mode), transfer speeds…and so on


  1. Flashed Pix6 (many times)… I installed the firmware from Ardupilot and returned back the official one from PX4
  2. I changed Windows and Ubuntu OS several times (20.04, 22.04) to do it all over again from scratch!

And I really don’t understand why this can happen! moreover, everything works with MP firmware, but not with native!(((that is, the hardware itself is working properly! the only thing I can’t get to is bootloader (this is another huge problem…because it needs to be compiled!!! but I have spent several days trying to do it, but it never happened!(there are always some problems and errors) is it really impossible to make a collection of firmware for STM???)

PX4-BOOTLOADER in this list there is no mention of the firmware for my device with the STM32H753 processor, as well as there is no information about which JTAG is suitable!

Well, I decided to write here out of desperation! Maybe someone has some thoughts?

I was able to solve the issue!)))

  1. through the mission planer, you need to access nsh on pixhawk (you can use telnet, you must first configure the network on pixhawk6x and on a laptop)

  2. after logging in, I reset all the parameters that I could change …
    command example:

  • param set MAV_2_MODE 0(assigning a new value to a parameter…see the list of all parameters in the documentation)
  • param -c show (view all changed parameters… that is, those that are different from the factory ones)
  • param show (overview of all parameters in general)
  • param save(save)
  • param load (load parameters by default)

after all the changes, I rebooted pixhawk6x and it began to be detected in QGC with native firmware from px4