QGC no airframe and parameters are missing from firmware

Good morning,

I am a new user of QGC and I am facing a problem with the Firmware installation. Also, since it’s my first time using this forum, I don’t really know how it works and my apologies if it’s not the right place to post my problem.

Here is the situation: Lots of parameters are missing after the installation is complete and I can’t select an airframe since none are displayed, preventing me from going to the next steps indicated on the documentation.

I am using the following setup :

Ubuntu 22.04 ;
QGC v4.2.8 ;
Pixhawks Hex Cube Black Flight Controller ;

I went through the forums and online documentation and try some of the proposed solutions but none of them worked for me. Here is the list of all the things I tested and didn’t work

*Reset all to firmware’s defaults( Vehicule did not respond to command : MAV_CMD_PREFLIGHT_STORAGE) and vehicule reboot failed.
*Try the differents versions of the firmware (stable, beta and master) ;
*Update bootloader (I have an SD card), can’t find parameters SYS_BL_UPDATE (even with the master version) ;
*Use a different version of QGC (4.2.8, 4.2.7 and 4.0.0) ;
*Use a different version of Ubuntu (22.04 and 20.04) on two different PC ;
*Test with another internet connexion (via cable and shared connexion with Iphone) ;
*Use a different pixhawks (Hex Cube Black Flight Controller and Holybro Pixhawk 4)

All of this always brought me to the same result and I don’t really know what to do. Your help would be very appreciated.

Thanks a lot.

I finally managed to solve my problem. I went on Windows, downloaded mission planer and flashed Ardupilot inside my pixhawks. Now it works with QGC (I don’t know why, I can’t load the version of Ardupilot proposed by QGC into my black cube).