Pixhawk can't connect to any computer

Hi. I’m using Pixhawk 2.1 Cube. I have a problem with my device and I’ve tried to solve this problem many times, I’ve tried many things but still not working. So I need your help. The problem is my device is not connecting to any computer. When I tried to connect via micro usb port, the led (yellow and slowly blinked amber) is on but I can’t see the driver in the device manager, I mean there is no difference in the device manager. So I’ve tried to connect via RFD and I can’t connect again. (I’ve tried this with other computers).

So interestingly, I’ve tried to connect with “debug” port and I’ve seen that the COM3 port is now available in the device manager but the leds are off. Just connecting but It seems there is no power in the pixhawk. So I’ve tried to connect MP again and it’s not working.

So I’ve tried everything but It’s not working. Please help me about this issue. Btw I can upload the video about the problem If you want . Thanks. Regards

  • What OS are you using?
  • Try a different USB cable and/or different USB port
  • It sounds like a driver issue. Have you tried uninstalling MP and all associated drivers with it, reboot, then try re-installing?
  • Try installing QGroundControl?

Good luck.

Do you have a firmware loaded?
Cubes ship without firmware, so you might just need to flash it: which doesn’t require “connecting” in Missionplanner.

Hello,

I have faced the same problem with the last revision of the black cube (those with a sticker on it).
Theses versions embed a new bootloader which is not compatbile with QGroundControl nor PX4 flight stack. They are only compatible with the last revision of Mission-planner
Also the manufacturer do not recommend running px4 software on it.

As a workaround, I have used the SWD/JTAG connector (pads present on the base board) to flash the bootloader which was found in the previous revision of the cube.
It can be easily done with a Segger Jlink plus or if you have budget constraint and are an hobbyist, using jlink mini and the desktop software J-Mem.
I’m pretty sure other JTAG debugger will allow you to do the same.

Good luck

Most likely driver hell.
Connect to a linux computer to check the hardware (QGC or APMPlanner2 should then see it on /dev/ttyACM0)