ESP8266 WiFi with PX4 Mini & QGC


I’m trying to setup my esp8266 to get a WiFi connection to my UAV/ QGC. I’ve followed the steps described in the following manual: The ESP8266 is flashed with the firmware-1.2.2 and I’ve connected it to the UART/I2C Bus of my Pixhawk PX4 Mini from Holybro, but now I can’t see it in the list of available WiFi networks.

  • ESP Connection: VCC + 18ohm R to get 3,5V / RX / TX & Pin 6 GND
  • Furthermore I’ve set in the Parameters GPS2 to Telem2 and set the baudrate to 921600 baud

Does anyone has an idea what the problem could be?

Thanks a lot in advance

I’ve read a lot and I think the problem is caused by the PX4 Firmware, because when I check the paramteres for sys_companion I can’t find anything. I’ve tried Beta, Master & Stabil but anytime I can’t find the paramter. Does anyone has an idea?

Simply supply the ESP8266 module (no TX/RX), wait a few minutes, and it should appear as an AP, where you can change its parameters (AP/station, keys, channel, baudrate, ports…).

Connect to its SSID (PixRacer/pixracer or whatever) at

Thanks for your reply, but some informations are missing.

I’ve connected the ESP8266 on the UART/I2C Bus:

But unfortunately I don’t know how to configure the port. I’ve checked QGC and tried setting up with the GPS2 config:

I’m able to connect with the Pixracer WiFi, but I’m not able to interact with QGC

I’m having this same issue, I flashed it with the 1.2.2 firmware using the procedure from
unplugged the usb from my FTDI, and then disconnected everything from the module except vcc and ground. then replugged my FTDI to supply power to the module. the light on it lit up, but I never see a wifi access point to try and connect to.
I tried connecting it to my pixracer, and plugging in a battery no joy there either. its like the darn thing isnt even there.