New Pixhawk 4, problem with Quad_H setup

Hello everyone, first post, so please forgive (and let me know) if I’m in the wrong place…

I just got the new Pixhawk 4 from Holybro (PX4 v1.8 firmware), with the intention of using it on a collective-pitch quadcopter like the Stingray-500 & Reaper-500, this one is the WLToys-V383. I’m using the PM07 power management board that comes with the Pixhawk 4 kit. I have selected the Quadrotor H airframe in QGC, using the Reaper 500 Quad type. Also, I have the Taranis X9D and the X8R radio for control, and the SiK telemetry radios from Holybro for the QGC connection. So all of the FC stuff is pretty standard.

Everything powers on and boots successfully, but the servos go to full clockwise when the vehicle is disarmed, and only go to centered when it’s armed. I failed two of the servos before I realized what was happening, so now I am making sure to connect servo rail power (from the BEC) only after arming the vehicle. I am using the I/O PWM Out from the Pixhawk connected to the FMU-PWM-In on the PM07, so that I can use the built in servo rails for servo control, instead of the normal motor control blocks around the edges of the board that you would typically use for a quad.

Part of the problem (probably the bigger one) is that I get absolutely no manual control over the motor or pitch servos with the flight mode in Manual, or any other mode for that matter. I can plug the servos and ESC into the radio receiver, and have full radio control over throttle (motor ESC) and directly to one servo on each channel for roll, pitch and yaw (not mixed) - so it’s not a physical problem with the radio or the servos or the ESC. And the radio calibration in QGC worked without any problem, too - the dots on the QGC screen move when I move the sticks. But the only thing that causes the servos to move is moving the Pixhawk around, activating the gyro sensors. Then I get some wiggle of the servos as they compensate for the movement.

My main question is this: Can someone tell me which output should go where for this airframe configuration, and do I have something crossed up? Is this keeping me from having manual control?

The Airframe Reference page isn’t that clear on this for the Reaper 500 Quad. The listing for the Quad H airframe says MAIN1-MAIN4 go to the usual motors (servos in this case, correct?), and MAIN5 & 6 are AUX pass thru - nothing is said about the throttle channel to motor ESC. I assume that’s specifically because the collective-pitch machine is different in this regard. I have tried the motor on MAIN5, and it goes full speed with no variation and no control when armed, so I am thinking that’s just not the right spot for it and it’s simply getting the AUX input as “on”.

I’ve tried to dig into the code, looking at the quad_h.main.mix, and 4040_reaper files - but I have a very limited understanding of programming, esp of C++, so I haven’t been able to figure it all out. I don’t see any obvious reference to throttle in any of this.

I understand this is an unusual configuration for most Quadcopters, but I would appreciate any input anyone can give.


Hi Brad did you end up finding your solution? I have a 383 and wanting to replace the fc where you successful in doing this?