Difference between QGC screen and User Guide

Hi folks. Take a look at this. First screen shot is my PC running QGC v4.3.0, which I think is the latest version. Second screen shot is from the guide. My version of QGC shows MOTORS, whereas the User Guide shows ACTUATORS with much more information on the screen. Why the difference? Is there any way to make these align so I have a clear idea of what I’m doing?

The later is possible with PX4 1.14 firmware version.

with PX4 1.13, check SYS_CTRL_ALLOC this parameter. works only for some vehicle type.

OK, I flashed PX4 v1.14 and booted up. I now have the Actuator screen. First I set up the frame config with dimensions. Then I powered up and all hell broke loose. The motors are making a screeching racket. Some of them sit there and screech and one rotates at full speed. The RC sticks have almost no effect. I can’t even disarm it.

I tried adjusting some of the PWM values in the chart but that didn’t work. Not sure what to do next.

So … where can I find out how to set this up properly. The user guide has not helped.


U have to perform ESC calibration if using PWM signal and not DShot. Then you have to adjust max and min PWM signal for your motors.
all things are available online on website.

I read the referenced material. First thing I did was calibrate the motors. This went OK and I got the message that the calibration was successful. As soon as that completed, the motors started their chirping again. I tried this procedure several times with the same result. Either I’m doing something wrong, or there is some basic issue with the PWM signals getting to the ESCs. In the past whenever I got the constant chirping, it is usually due to the RC radio being off so that there are no PWM signals. But in this case, the RC radio was on and by moving the sticks I could make some motors turn on at full speed while all the others were chirping.

Any further suggestions?


Something I have noticed on both PX4 1.13 and 1.14 is that the safety switch located on the GPS module does not make any sound when depressed. If it supposed to cause a series of beeps like it used to, then that indicates a malfunction.

I still can’t get v1.14 to work. The chirping motors are driving me crazy. Is anyone else having this trouble?

  1. What ESCs are you using
  2. What airframe did you select
  3. Can you please show a screenshot of your actuator setup screen?

The ESC calibration instructions are a good entry point for this. ESC Calibration | PX4 User Guide (main)

Also the main config screen, though it will take you through the same path: Multicopter Configuration | PX4 User Guide (main)

ESC making sounds means they are getting signals to do something when they shouldn’t be. If the slider is at the bottom the disarmed value should be being set. That value should be 900us by default - is it? If not, set it to 900 and see what happens.
If it is then try a recalibration.

ESCs: DJI E Series 420S
Airframe: DJI F550
I have been flying this drone since 2018 and it has hundreds of flights using prior versions of PX4. But v1.14 is a very different animal and so far I have not been able to get past the Actuator calibration procedure.

Below is a screen shot of the Actuator setup. This is the way it looks when I start the motor cal from the Power tab. Like I said, as soon as I get confirmation that the motor cal is complete, the motors start to chirp.

Some new information:
Not all of the motors are chirping. As the chirping was going on, I put my fingers around each motor. The ones that were vibrating were 2, 3 and 4 in the diagram. Three out of six. Does this provide any clues?

Another update: finally got the chirping to stop. I basically started from scratch. Set all params to default, shut down QGC, unpowered the drone, turned off the RC radio. Basically a cold start. Powered up the PX4 and manually reset all the params I had changed, checking them against a master list I keep of key setup params. Plugged in the main batteries and everything was quiet. Halleluiah!

Now I can arm the motors, but they will not respond to throttle commands! No rotation.

In the Actuators Setup, the sliders do nothing. If I press on “Identify and Assign motors” and choose Yes, the screen greys out. None of the motors spin up and the sliders are greyed out too.

I’ll keep working this but some more suggestions would help. This is the most frustrating release of PX4 I’ve ever used.

If you have assigned a kill switch and it is on, then also motor slider won’t work. So check for it. May be your minimun PWM value for each motor is quite low,
remove all props, move the slider all the way down, set disarm to 900 and then change disarm PWM value of motor 1 in step of 25 and check at what PWM value it is rotating. Set that as your min PWM value. and change your disarm value to 100 less than that value. Do same thing with max PWM value, move the slider all the way down. and change your disarm value to 1900 and change the value in step of 25 and check, when motor is not rotating any faster. set that value to max pwm value and change your disarm value to 100 less than you min pwm value.

if still not working change from aux PWM to main PWM and check.

I have the 6 motors assigned to PWM AUX 1 thru 6. I have the RC Tx assigned to PWM MAIN 1 thru 4. These are THROTTLE, ROLL, PITCH, and YAW. Without the drone being armed, three motors rotate! When I arm it, some of the other motors start to rotate, some at higher RPMs than the others. It’s absolutely bizarre. I have no idea what’s going on. And there’s no way to stop the motors that are running unless I unplug the battery. Absolutely weird.

I’m about ready to scrap v1.14 as a waste of time.

I have not found a way to arm and start all the motors at the same time using the information in the guide. Should the motors be in PWM_MAIN and the Tx inputs be in PWM_AUX? Which is opposite to the user guide. I tried this and it seems to work. I can now arm the motors and start them all at once. However, now there are 10 sliders because the Throt, Roll, Pitch, Yaw have been added! See below. Is this correct? and what is the purpose of having the extra sliders? I’d like to get some more explanation of exactly how this all works.

Why you need such thing? Isn’t roll, pitch, yaw and altitude controller by motors directly? It is hexacopter only.

I had to assign the RC inputs otherwise nothing worked. And yes it is a hexacopter, but the mixing is done in the Pixhawk. I think the instructions about assigning motors to the PWM AUX inputs is wrong. I could not get that to work. However, assigning the motors to the PWM MAIN input works.

If it is only hexacopter, you don’t have to assign roll, pitch, yaw and throttle to any pwm aux or main via RC through.
you must calibrate your radio control and that’s how you control angular rate and throttle.

1 Like

I disabled all PWM AUX inputs and put the motors on PWM MAIN 1 thru 6. It works. I now have all the functionality back. I can see now that I don’t have to map the RC inputs to the Actuator PWM AUX screen.

Thanks for the help.

Good to know. Just choose one of my replies as accept as answer.