Missing control signals from Pixhawk

Hi, I’m trying to build a rover with pixhawk 4 and QGC, but I’m kinda stuck at the moment. I connected the PM board, FC, and Radio receiver with airframe of R1 Rover then tried to run a servo motor, but it didn’t work. I checked the PWM is going into PM board properly, but I can’t find main control signal at the end of output point on PM board. I removed the safety switch long-time ago, so it’s not gonna matter. I calibrated every single sensor properly, and radio signal also worked quite well on the screen. RCMAP channels are already set as preset frame of the airframe model I chose. Is there anyone having this kind of problem? I’m also suffering with the problem that I can arm the vehicle without any problem but cannot un-arm it with my radio. I think these two problems are quite related.
Need your help desperately.

And you set the parameter so the safety button is not required?

That’s probably a feature so you don’t accidentally disarm. Disarming will have to happen via safety button or QGC.

You can also integrate with this PM board using serial and the roboclaw driver. I’m not sure what is enabled by default. Check these params to figure out and if change the configuration if required:

In theory both should work: PWM output or the roboclaw driver, however, I’m not sure what is enabled by default. @Timothy maybe you can help here, thanks.

By default, PWM should be enabled. However, you’ll have to configure the Roboclaw to accept PWM signals. See the Roboclaw documentation here (Page 35, set it to “RC Mode with Mixing”).