PX4 Rover no PWM out

#1

Hi all,

currently trying to setup PX4 firmware v1.8.0 for a rover. After configuration and sensors calibration no PWM signal on the output pins

I tried with Generic Rover and Traxxas but the behavior is the same, no PWM output.

Some additional notes:

  • I’m using a companion computer in offboard mode, no radio connected
  • I’ve disabled several CBRK_xxx params to disable checks (RC, IO_SAFETY, SUPPLY)
  • using Mavlink Console and passing the command “pwm test -c 2 -p 1200” steering works, same with “pwm test -c 4 -p 1800” throttle works fine.

Any help? I know that this issue was a firmware bug, is it still present in current version?

Thanks, cheers

#2

Hi, I can concur your experience as I have had the exact same issues with PX4 v1.8.0. I am very disappointed in that it seems the rover code has been abandoned by the PX4 dronecode developers.

I was trying to implement the same set up on a Traxxas X-Maxx which appeared dead on start. Like you, I went through all Rover profile options, set the start up profile parameter number myself, I went over the set up countless times. Pixhawk would often seem to forget what it was set up as and even deleted the Rover profile form the Airframe options. I had to reinstall a fresh version of QGC to get the option back, just weird!

After trying everything, reading every topic on the Rover subject posted on the forums, begging for help from the community, rewiring and re-loading firmware and in general freaking out, thinking I had killed my rover (purchased by my company for research) I installed ArduRover and it sprang to life! It just works.

I am very disappointed not to be using the PX4 stack firmware as my flight vehicle is currently loaded and working with v.1.8.0 and my team has many work hours invested in the firmware. Upon deeper investigation we will be making the move over to ArduPilot completely going forward.

I would love to hear what the PX4 stack developers have to say and shed some light on solutions we can work with.
In order to move your project forward, I recommend you make the move to ArduRover.

Best of luck!

#3

Hi Nexus6,
I understand perfectly your feeling and your disappointment, it’s the same for me. I’m working on a project that involves a swarm of 5 drones and 3 rovers. With the multicopter I have no problem using PX4 and for consistency I wanted to use the same with the rovers, but at this point we will be forced to pass to ArduRover that, at a first test, we have already seen that it works with a companion computer in Offboard mode (Guided).

Thank you for your consideration.

#4

I had same experience, and same desire to complement drones with rovers. Year of time invested in PX4. I had to go back to something like 1.6x to see any signal.

Will try ardurover…

#5

I had a similar problem when starting with rover. Found there was a bug in the rc.ugv_defaults file. The line - set PWM_AUX_OUT 1234 overwrites your control group. Notice just above the line set PWM_OUT 1234. Comment out the gimbal mixers and you should get your motor pwm signals going to the correct control group.

#7

solved yet? I have the same problem

#8

Could you show the code modified please?

#9

Hi,
I don’t have the code on this computer - would have to dig for it. But, I did want to comment quickly. The problem is that the control group that operates the motors is being overwritten in the rc.ugv_defaults file. Simply comment out or delete the line PWM_AUX_OUT 1234. If you are still having issues with it, I will be able to get more information to you in the next few day or so if needed.

#10

Thanks a lot!

But I commented out all the lines in the picture,nothing changed:disappointed:

Any suggestions?