NO PWM SIGNAL OUT - Pixhawk (Rover)

#1

Hi all,

Currently trying to setup my Pixhawk (latest firmware). The pixhawk is configured with rover configuración; I have calibrated the sensors and battery.

I have an Oscilloscope hooked up but I dont see any pwm signal on the output pins. I used Qgroundcontrol and Mission planner for the configuration, but none worked.

Is there some arming procedure that needs to happen?

Cheers,

Cesar Vega

Status on Px4 rover
#2

I have the same experience, its making me crazy. Is ROVER still supported? I see nothing with my logic analyzer on all signal outputs, even in ARMED state.

#3

I have found that ROVER using PX4 1.6.5 does have signals coming out. 1.7 and above all produce nothing. Seems like something has been broken for a very long time, or I am not understanding something. I will continue to develop using 1.6.5 but it is quite old…

#4

Hi Strongbad71, same problem with 1.8.0. Following your suggestion I uploaded the 1.6.5 version but issue still present. What type of airframe did you select? I tried with Generic Rover and Traxxas but the behavior is the same, no PWM output.

Some additional notes:

  • I’m using a companion computer in offboard mode, no radio connected
  • I’ve disabled several CBRK_xxx params to disable checks (RC, IO_SAFETY, SUPPLY)

Thanks, cheers

EDIT: using Mavlink Console and passing the command “pwm test -c 2 -p 1200” steering works, same with “pwm test -c 4 -p 1800” throttle works fine.

#5

Hi, sorry for late reply. I didn’t do anything special, I selected ROVER in QGroundcontrol as you would expect. I might have used Traxxas. I hooked up a logic analyzer to the Pixhawk outputs and I could see signals on some of the pins, not all of them. Did you look at all signal pins using 1.6.5?

Anyway, regardless, I am switching to Ardupilot for the Rover project I am working on. I can’t be using something that is unsupported at the moment.

#6

Hi, I tested PWM with 1.8.2 and CUAVv5, and disabled several params as you. I found the PWM output of throttle was between 160mv and 240mv

#7

Hi,

Did you find the issue?

BR,
M