RC not mapping to PWM main out bug?

#1

We are trying to setup PX4 on a Pixhawk 2.1 Cube. I have flashed px4fmu-v3_default after building it from v1.7.3 of the firmware. The RC controller was calibrated and confirmed through analyzer in QGC. We selected the generic UGV because our vehicle is a rover (S10 Twister Motor with Runner Reverse LRP v2 ESC). We have also tried the other UGV airframes with similar results (e.g. stampede).

Logging into the Nuttx console and manually issuing

pwm text -c 2 -p 1600
PWM rate was changed from 400Hz to 50Hz.
The servo that controls the steering is located on channel 2 and turns successfully.
The ESC on channel 4 controls the main motor. Issuing
pwm steps -c 4
successfully powers the motor and spins the wheels (however, it did step beyond the PWM bounds).

We have identified a problem, which is that inputs made from the RC controller do not modify the values of the servoX_raw main outputs. This is observed in the Analyzer. We have armed the system when testing this. We have tried with the RC controller in both PPM and SBUS configurations. We have tried multiple Pixhawk 2.1 Cubes and can rule out a hardware connectivity or failure problem. Also, we can successfully observe it working when loading ardurover (latest version). We would like to get this to work in PX4. We have gone over all of the parameters via:

param show
Any help would be much appreciated. Is what we’ve found a bug?

Output of px4io status

Output of ver all

Screenshot of Analyzer with the servo values

Please help!

1 Like
#2

I have the samilar problem…haven’t solved yet