Pixhwak 4 with PM07 board no control for servo using RC

I have connected the px4 to PM07 board and also connected 1 servo on FMU-PWM-out 1 pin of PM board to check if it is working or not. But no control from RC. I used oscilloscope but there is no signal on this pin. But the Futaba receiver shows signal on channel 1 when i move the joystick

Please refer Pixhawk 4 Wiring Quick Start | PX4 User Guide on setting up connections, depending on airframe reference connections might change.

Also note that the FMU-PWM-OUT pins are unpowered, you need to power them separately using a BEC.

1 Like

Thanks for response. Actually I am powering FMU-PWM-OUT pins using a BEC. Also I have tried to setup connections in all different ways that (Pixhawk 4 Wiring Quick Start | PX4 User Guide) suggests. The problem is that it doesn’t respond when I try to control using RC.
But I have checked that when I test motor from Qgroundcontrol Motor setup the M1 pin or FMU-PWM-OUT 1 Pin respond and the motor works depending on which setup connections between PX4 and PM board I am using. My problem is that when servo connected to PM board it is not responding with RC neither there is any signal on oscilloscope from FMU-PWM-OUT or M1-8 pins when I give command from RC.
For my confirmation i plugged in the servo directly to Futuba receiver and it worked properly with RC commands.

Have you tried arming the device. I think its disarmed, please press the safety switch that comes with the gps or enable it through qgc parameters.
https://docs.px4.io/v1.11/en/advanced_config/prearm_arm_disarm.html

1 Like

Thanks for the solution it is working now.