How to setup HK 433 Mhz telemetry radio with Pixhawk 2 cube and Qground control

Hello,

I am trying to resurect an old project I never finished. So I have an pixhawk2 cube connected with telemetry radio ( HK Model no HT0x ) . One is connected with USB to my computer and the other to the pixhawk both have solid green light with blinking red which mean they see each other and communicate. However QC control doesn’t see the link automatically and when I create it manually it doesn’t work.

My physical setup

The parameter of the radio in QGround controlRadio1

The error when I try to connect :

I read on forum than you could deactivate the autodetection of the telemetry so I also tried this path :

But It doesn’t change anything, should i need to install some specific driver ?

radio4