Pixhawk Cube does not Communicate with QGC via 3DR Telemetry in Ubuntu

#1

Hi guys,

I am using Ubuntu 16.04. I was not having problem about the communication between pixhawk cube (with PX4 flight stack) and qgroundcontrol via 3DR telemetry (433mHz). Before a flight, I cut the cable of air telemetry (unintentionally). After that, I ordered a new cable. However, I cannot have wifi communication between pixhawk and QGC anymore. If I use USB connection, there is no problem. I am certainly sure that I made the cable wiring correctly. Also, I have tried some recommended solutions on the Internet for a while. For examples;

  1. I installed APM Planner. It also does not communicate with pixhawk.
  2. I installed different releases of QGC. It did not work. Moreover, It started giving more and new errors that I have never encountered before. PS: I was not having any error when I run QGC ever.
  3. I formatted my pc because somebody told me that this problem is about OS.
  4. In case of wrong wiring of new cable (5V, RX, TX and GND), I switched RX and TX each other.
  5. I have used another pairs of 3DR telemetry modules (another 433 mHz and 915 mHz).
  6. Lastly, I deleted everything inside the sd card of pixhawk since it was also recommended on an internet page.

Those above did not provide any solution. What I don’t understand is that It was working without any problem just before cable was damaged. What can be the problem ?

Although I implemented 6 things above, please don’t hesitate to tell me to do one of them again if you are sure that I am doing wrong.

Thanks, Ender.

#2

What Telem port are you using? If it’s plugged into Telem1, have you tried configuring it for Telem2?

Have you tried reloading the firmware (save parameters first then reload)?

You didn’t specify what wires you cut but if it was a power wire together with one the others, could it have shorted out something inside the Pixhawk? Otherwise, with the telemetry radio unplugged, is the Pixhawk performing normally?

Good luck.

#3
  1. I use Telem1 for telemetry because Telem2 is for companion computer.
  2. I did not reload the firmware by saving the parameters. But I reloaded with different version of firmwares.
  3. 4 wires (Power, TX, RX and GND) were cut off simultaneously. When cut off, there was no power through pixhawk. Pixhawk seems normal. But I also suspect about inside the pixhawk because of other reasons, for example, I provided power and cut the power from pixhawk lots of time and consecutively.

All in all, to my feelings, It is about system settings or in-compatibleness of something. Because, QGC gives different errors when starting it each time. Before this problem happened, QGC never gave any error when starting it. It was completely stable and robust.

Thanks for your analysis.

#4

Download and try using the 3DR/Sik Radio Config Tool . This will confirm if both air and ground radios are able to connect and communicate with each other. The tool can also update its firmware. Once it’s updated and confirmed everything matches, try it on the Pixhawk.

Good luck.

#5

Thank you. I will try it and post the result here.

#6

If you have an FTDI breakout or cable, just make a board to test either end of your telemetry link. Plug in both radios and use minicom on /dev/ttyUSB0 and /dev/ttyUSB1 - if you type in either you should see characters. That will tell you if you blew up the UART pins on your pixhawk and help you divide/conquer on the problem. You can also use one of the TELEM3/4 ports if you blew up TELEM1.

#7

Check are they paired - green light (or similar) on both of them. When transmitting, does the transmitter blink and the receiver blink simultaneously.

Other than configuring them properly as described above (Config tool link), plugging them both into a usb machine (Windows or Linux) and typing on one and seeing it appear on the other is the foolproof way to test.

Good luck
lc