Help! No Outputsignal on px4 v2 autopilot

Hi Guys

I bought an Pixhawk from Banggood (link below), flashing the board via MissionPlanner works normally, also the board acts like everything is right. But if I connect a Servo or an ESC there is no respone. I then connected an oscilloscope and there is no PWM Signal. I then tried to flash older firmwares, at one point I got a correct PWM Signal, but when I rebooted it, the signal was gone agaon on all outputs.
Can it be that there is a firmware issue, or is it more likly that the board is funky?

Thanks for your help :wink:


Sounds like the safety switch is enabled (it is by default). If it’s fitted, pressing it will allow the output signals. If it’s not, you can disable the parameter (brd_safety_enable in missionplanner, use the full parameter list and search for it).

1 Like

Thanks for your answer!!
I force armed it via MissionPlanner, that should overrite the safetyswitch, or am I wrong?
I also saw on the status page in missionplanner a value at output 1-4 and when I toggeld for example output 5, the value on that output became also active, but no PWM Signal at any output could be measured.

Yes is it right , also calibrate all sensor + confirm your frame design.
Main thing is what’s telling your screen , any warning show that ?

Happy flying :slightly_smiling_face:

1 Like

have you confirmed that all your min, max, disarmed, failsafe values are sensible in the parameters? I found all my values were at -1 at the beginning and as a result there was no pwm on any ch output pins, armed or not, until i ranged them to 1000-2000us etc.

1 Like

On the status page the Outputs 1-4 seem to output always a signal in the range from 1000-2000 (if armed or not), all 1500 and the throttle ouptut 1100 as I think they all should. If I toggle for example the output 5, the output signal on the status page goes from 0 to the correct value between 1000-2000, but I can not measure a PWM Signal on the output. I changed no settigs, alle default settings from ArduPlane V4.0.5. I didn’t connect anything only a receiver via the RCIN, So there are the usual warnings like no GPS and bad Compass health. I also tried it with everything connceted in the plane, but that didn’t change anything.

For ArduPilot assistance, best to ask at
(and I’d check the parameter I suggested above…)

1 Like

The status page data is pre- the min max limits. I also had status page showing data but made no difference, in my case the min and max for all channels were -1us which prevents any output.

have you got sensible numbers here?

1 Like

This thread really needs to move to

1 Like

Yes Patrick seems to be running ardupilot FW,

1 Like

Sorry for posting it in the wrong forum, I posted my problem now on the ardupilot forum.
Thanks all for your answers and the help!!

Kind regards