Error "Detected 0 radio channels. To operate PX4, you need at least 5 channels"

#1

This is my first drone and I’m really having problems.
Q Ground Control cannot detect any radio channels on my drone… It was detecting the radio channels and all seemed well. I then changed my ground station to mission planner and flashed ardupilot firmware to it and also detected the radio channels… Now, I had connected all my ESC signal cables to the receiver channels.
Mission planner couldn’t also perform the motor test. I get the error “command was denied by the autopilot”
When I tried to takeoff, of course with much difficulty from the radio, the quadcopter attempted to lift, one side must have generated more lift and it toppled upside down. One of the motors and it’s ESC seemed affected as there was smoke from the both of them (motor and its ESC).They also felt very hot. The motors seemed to try to rotate even when the vehicle was upside down and the transmitter was off. So I disconnected the vehicles battery. When I later tried to connect the vehicle to the mission planner, radio channels were not being detected. I switched back to using Q Ground Control as my ground station, flashed firmware back to px4 and it couldn’t also detect the radio channels…
The motor that smoked seemed to be unaffected
The following is my hardware:
Autopilot: pixhawk 4,
Power: pixhawk 4 PM07 power management board.
Motors: Sunnysky x4108s 380kv
ESCs: hobbywing xrotor 40amps
Radio: Radiolink AT10 II transmitter, Radiolink R12DS receiver, Radiolink PRM-01 battery voltage telemetry sensor.

What could be wrong?
Why aren’t my radio channels being detected by the ground station?
Why couldn’t mission planner perform the motor test?

Here’s the link to the pics: Error "Detected 0 radio channels. To operate PX4, you need at least 5 channels"

1 Like
#2

Good day,
did you connect your receiver from the rc pins of your fc to the sbus of your receiver?

#3

Yes I did… Tried all sbus and rc connections but it changes nothing. My receiver supports both sbus and ppm.

#4

ok… how about the settings on your transmitter?
can you send me pls a pic about the wiring you have done?
After the connection did you bind the tx/rx

#5

Yes… I did bind the tx… And did the ESC calibration.

#6

ok… i need to check you wiring with a picture

#7



I’m not sure what this is for:

#8

good day
sorry for late reply, the small board in your hand is a pwm board, just try to connect the pwm board to your fc…

#9

@BartLeonard sorry to hear about your accident. Did you have any luck connecting your receiver to the pixhawk (via the SBUS port) without the PWM board? (I do not have this hardware)
@Dave84
I received this same error but with the pix hawk 4 mini. My auto pilot never registered the receiver when attempting to plug into the mini’s Radio Control Receiver Input.


I asked the question here if you are interested in helping. http://discuss.px4.io/t/pixhawk-4-mini-and-x8r-not-working/9406

On the other hand, I was able to get my pixhawk 4 to recognize the same reciever via the SBUS port that BarLeonard originally tried to connect with. If you have any troubleshooting advice can you please help.

Thank you,
-Jordan