Pixhawk IO not working

So I recently got a pixhawk 2.4.8 and I actually had it working to the point that I could hover my drone for a little bit. The next time I tried to boot everything up I noticed that the red led in the safety switch wasn’t flashing and the only light on the board was the green FMU PWR led. The beeper also didn’t make any noise. Mission Planner shows check BRD_TYPE px4io failed start. I was looking around before posting and most of the posts that I found said I either needed to reflash my firmware but I can’t do that in the board’s current state with mission planner (it hangs on scanning comports). I changed BRD_IO_ENABLE to 0 which caused the buzzer to work on startup again, as well as the main LED to start flashing again (double yellow for failing pre arm checks) but now I can’t connect to my radio anymore. I also tried reformatting my SD card but that didn’t work either. It seems like Check BRD_TYPE px4io failed start has the same (or almost the same) issue as I’m having but unfortunately there wasn’t an answer. Thanks for any help you guys can give.

It sounds like you’re using ArduPilot, so best to ask at discuss.ardupilot.org
To perhaps get you going though: disabling the IO board disables your RC input for that autopilot, so no surprise it doesn’t work with that parameter set. You can configure a serial port as RC input for some protocols though. https://ardupilot.org/copter/docs/common-serial-options.html#serialx-protocol
You’ll also need to move your motor/servo to the Aux connections.