GPS is not getting detected in Pixhawk when switched to Guided/Auto/Loiter mode

I am trying to change pixhawk’s mode to Guided but it is not taking GPS
lock which is required for Guided mode. Also, it fails in Loiter or Auto
mode. if we dont switch to any mode then gps able to take lock(green
light glows)I am using Ublox GPS and it seems there is no issue with the
GPS as I tried connecting to other GPS but still no luck.
firmware version :- px4 3.3

Actual PX4 release is 1.4.4. Are you running the APM flight stack on your pixhawk?

Hi timoski, thanks for your quick reply.

Yes, I am running the APM on pixhawk. So, When I change to a flight mode that requires a GPS fix (auto, guided, loiter or rtl) my pixhawk will ignore it and start blinking blue. And as soon as I switch back to a mode that can work without a GPS it will start blinking green.

Now, I have checked all the GPS related parameter and they are configured to use GPS. I have used these modes with GPS successfully before, but now it doesn’t work.

First you should check in MissionPlanner if you have a GPS fix. With open sky you should see at least 6 sattelites in Mission Planner. If not there is probably something wrong with your GPS or the connection to your GPS.

For further support regarding the Ardupilot Software Stack please post your question at

@rahul_kumar did you ever find a fix for this? I’m having similar issues getting the quad to HOLD