Take off stability of a custom frame

Hey :wink:

I built a quadcopter similar to Holybro’s QAV250 but with an NXP flight controller. I installed px4 firmware and calibrated sensors and ESCs. I have the following issues:

  1. Controller issue: I noticed after arming I can increase the motor speed accurately with the RC controller but I can’t decrease it anymore before actually taking off (Video).

  2. after taking off in stabilize or manual mode, the drone goes to one side, and it’s really hard to control. I barely left the surface and it flies to the right side and sometimes a little backward. I didn’t increase the throttle because it’ll make it move to the side even faster and harder to control (video).

Any suggestion on how I can fix these issues?

Does creating a new custom airframe help?

  1. It will keep spinning because there is a minimum throttle set, which makes sense, even though it might be a bit high. Have a look at the PWM_AUX_MIN, or PWM_MAIN_MIN depending on where your ESCs are connected to. Or use the Actuators tab in QGC.
    Then, you presumably have airmode enabled which means the controllers are active and integrators are winding up and leading to the high motor speeds that your observing. You can try to disable that using MC_AIRMODE.

  2. It looks and sounds like the model is quite under-powered for its weight. This likely means that you don’t have much control authority to actually be well controlled, and properly take off. As you’re trying to take off, it keeps hooking onto the carpet which leads to the controllers working against that and integrators winding up. This means that the controller is “out of balance” when you finally take off and so it takes a few seconds to get back to balance. On top of that, your frame might be slightly out of balance or you might have air moving around in the room. Both of these things, the Stabilized controller will not compensate for, as it is very much a “manual” or “prototype” mode rather than something like position control which helps hold the position using something like flow, VIO, or GPS. Basically, you can’t expect it to hover nicely on the spot like a DJI because that one has vision and maybe flow helping it to do so.

I would probably suggest to get a bit more familiar with flying PX4 with a frame that is less under-powered, to learn to fly.

1 Like

Thank you for the tips. According to this documentation (Actuator Configuration and Testing | PX4 User Guide) I can adjust the position of the motors but I couldn’t find them in the QGroundcontrol (screenshot).

Hmm, good question. So how can you make the new actuator control panel appear :thinking:

Open the view in QGroundControl here: “Q” (app menu) > Vehicle Setup > Actuators (tab). The displayed elements depend on the selected frame, with outputs mapped by default as shown in the Airframe Reference.

@bkueng which airframe uses the new config? Or how could @Kurosh get the new setup?
I believe one way would be to build and flash the main branch rather than the latest stable (v1.13.2) release…

On 1.13 you can just enable it via SYS_CTRL_ALLOC=1. The versioned docs still contain the hint: Actuator Configuration and Testing | PX4 User Guide.

1 Like