Motor test command not supported

Going through my first setup with QGC and have most parameters accepted. Now attempting to test motors and getting:

Motor test command not supported.

Running new Holybro Pixhawk 4 kit. QGC firmware: V1.10.1

Any thoughts, thanks in advance…

1 Like

@ChrisDaily what airframe have you selected?

@bkueng is this expected?

Yes it’s not in v1.10 yet.

Generic hexarotor x geometry the drone is a hex Tarot 680 with Pichawk 4

Hmmmm as I am new to this form of drone, is it not wise to load latest? It was the first thing QGC asked. LOL

Is there a way to roll the version back?

Tried rolling back off of 1.10, not sure it worked. Anyone have any idea how to do this?

Still getting: Motor test command not supported.

You need to install master (daily build), or the beta version might work as well.

I have same issue… motortest unavailable but I can test the motors individually in the prompt with motortest command.

I contacted donlakeflyer in an earlier post, he thinks it is Some firmwareversion on flightcontroller, I was not able to test this but updating firmware throughout QGC doesnt work.

I use fmuk66 and a possible solution would be updating firmware to develop version, reboot… then update again but choose stable version again, some flight controllers let you choose version numbers for fmu firmware, this did not work for me but somewhere on this forum this solution helped some.

I like to hear solution too :+1:t2: Good luck

I have same problem.

  • Flight controller: pixracer
  • Firmware: px4fmu-v4_default.px4 v1.10.1(I tried v1.10 and not worked too)
  • PC: macOS Catalina, v10.15.5
  • QGC: latest(4.0.9)

Same issue here.
Is this s bug? If so someone should enter in to the git issues.
See issue:

qgroundcontrol error: Motor test command not supported #15313

I am told this is for 1.11
With 1.11 Beta 2 you get motor test denied until you arm then it will work.

Looking for the answer too

Hi @SonyJP welcome to the group!!!
The answer is you must use 1.11 Beta to get the motor test command.