Not sure what settings need to be in QGroundControl (4.3.0) for my Pixhawk2 (Cube Black) running PX4 1.14.0 to be able to use GPS data from a CUAV C-RTK 2HP.

I’ve tried using the CANbus connection:
Wiring: “CAN” on unit to “CAN1” on Pixhawk2.
LEDs on GPS Unit: PWR = lit, PVT = lit, CAN = 5 rapid pulses repeated over and over
Parameters: UAVCAN_ENABLE = Sensors Automatic Config

  1. QGroundControl on the computer (via USB) can no longer get parameters from PX4 (Restored connection by using QGroundControl on the controller, Herelink 1.1, to change UAVCAN_ENABLE = Disable)
  2. No GPS Lock

I’ve tried using the UART connection:
Wiring: “UART2” on unit to “GPS2” on Pixhawk2
LEDs on GPS Unit: PWR = lit, PVT = lit, CAN = 5 rapid pulses repeated over and over
Parameters: GPS_1_CONFIG = GPS2

  1. No GPS Lock

I’m not even sure if the GPS is communicating with the PX4.
QGroundControl’s Console shows these 3 messages:
"[E] at qrc:/toolbar/GPSRTKIndicator.qml:26 - “qrc:/toolbar/GPSRTKIndicator.qml:26: TypeError: Type error”
"[E] at qrc:/toolbar/GPSRTKIndicator.qml:93 - “qrc:/toolbar/GPSRTKIndicator.qml:93: TypeError: Type error”
"[E] at qrc:/toolbar/GPSRTKIndicator.qml:105 - “qrc:/toolbar/GPSRTKIndicator.qml:105: TypeError: Type error”

Really, my question is what settings do I need to set in QGroundControl for the PX4 to use a CUAV C-RTK 2HP GPS (dual antennae) unit?

Does this GPS connect via UART or CAN?

And which target are you flashing on the Cube Black? fmu-v3?

I’m also using C-RTK 2HP device for Heading angle correction.
I connected rover GPS with CAN setup. Later enabled
UAVCAN_ENABLE = sensor Automatic config

This setup worked for me to setup both base and rover GPS to work.

Now I’m planning setup Dual antenna based heading setup on rover GPS side, i’m not sure which parameters need to setup in QGC for activate dual antenna as heading system. I followed Ardupilot documentation they have enable heading system by editing below params,
EK3_SRC1_YAW = 2 or 3(heading source, 2: use GPS heading. 3: use GPS first, compass as backup)

Antenna offset setting
GPS_MB1_OFF_Y=0.43 #The Exact total distance between each other

Position offset setting
GPS_POS1_Y=0.215 #Distance per side in y-axis

Similar to these parameters in Ardupilot, which are the parameter need to set inside QGC or since we have set UAVCAN_ENABLE = Sensors Automatic Config, does it automatically assign params itself for activating heading system.
Hi @JulianOes, any suggestions for activating dual heading system with QGC.
Thank you.

It can connect via either one. I’ve tried both. I do not get a GPS Lock with either connection.

Yes, it is the Hex Cube Black (formerly known as Pixhawk 2.1) based on the FMUv3 open hardware design: Hex Cube Black (FMUv3) · PX4 User Guide

Did you follow this?

I followed same document and i setup the all the parameters as suggested in documents but still my system not using the dual RTK for heading corrections. It still taking compass information for heading, I tried to disable compass completely but when I disable compass vehicle is not coming position mode.
I’m using pixhawk 1.13.0 firmware version, in earlier I used ardupilot firmware and able to get heading corrections correctly. After I moved to pixhawk firmware I’m not able to get proper heading corrections.
Any suggestions for tuning particular params in pixhawk 1.13.0 firmware to activate C-RtK 2HP as heading unit.

Does this issue can be resolved if I moved into pixhawk firmware version 1.14.0? where can I find pixhawk 1.14.0 bootloader flash image(.px4).

When you flash latest stable in QGC, does it not install v1.14?

Yes, currently flight controller running with v1.14.0 firmware. Able to get 3D RTK Lock fix with ground station setup. The problem is still dual antenna based heading system not enabled. It still taking considering compass as heading unit.

I observed that, when i set EKF2_MAG_TYPE= None, it might gone not using compass as heading source, but this time propeller itself not arming even after all the pre-flight checks are passed and system saying Ready to Fly. The error it prompting is “Arm/Disarm command temporary rejected”. I don’t how to debug this, I have attached the full parameters list for reference. Kindly suggest me if need to any params to overcome this issue and use dual RTK heading as YAW estimation for drone. Parameters configured are,
EKF2_GPS_POS_Y = 0.43 (Since Dual antenna are loacated at y-axis between 43cm each other along COG point)
UART communication
EKF2_MAG_TYPE = Automatic

Not sure to set GPS_UBX_MODE param, since using C-RTK 2HP rover gps setup comes with one GPS with dual antennas.

CUAV customer support has provided a solution that works! Hardware/firmware/software setup is the following: QGroundControl (4.3.0) for my Pixhawk2 (Cube Black) running PX4 1.14.0, GPS is the dual antenna CUAV C-RTK 2HP.

You need to follow the instructions found here: Users manual for PX4 · C-RTK系列GNSS

We had trouble finding the UPrecise software at first, but finally found a place to download it here: Unicore UPrecise application
Windows gave me a warning that the software was potentially unsafe, but it ended up being just fine.

All of the options and settings as outlined in the aforementioned instructions worked great. The only other issue was selecting the correct Serial port configuration in PX4. The C-RTK connects to the GPS2 port (not the GPS1 port). Within PX4 there isn’t an selection option for GPS2 (although some older comments say to use “202”, but that doesn’t work). I found though that GPS2 is mapped to TEL4. So for the parameter GPS_1_CONFIG, you need to select TEL4 (“104”).