UM982 dual Antenna heading


I am using um982 dual antenna module for yaw along with RTK. I followed the steps given in the PX4 guide. I can see the yaw movement when i rotate the drone but irrespective of drone orientation it is pointing north always whenever i restart the controller and from there it is rotating.

Using PXcube orange. Antennas are mounted on front and back with 30cm apart.

I would guess that GPS heading is actually not working and it’s instead just initializing North on boot up.

What’s your EKF2_GPS_CTRL parameter?

EKF2_GPS_CTRL parameter value is 15

I heard of a report where the heading message had to be turned on in the Uprecise tool. Have you tried that?

@JulianOes Thank you for the reply.
Yes, I reported that after testing.
Actually issue was with the Holybro default configuration. GPS is sending completly wrong message and Pixhawk doesnt have parser for that so it was not working. Later I enabled the requried message and it started working.
Details about the issue: Holybro UM982 GPS heading · Issue #139 · PX4/PX4-GPSDrivers · GitHub

Run the following commands in UPrecise tool to get the heading output from GPS


Which message is it sending by default? Maybe we need to add parsing for that one?

Default output from UM982 for heading


Px4 required format:

#UNIHEADINGA,97,GPS,FINE,2190,365174000,0,0,18,12;INSUFFICIENT_OBS,NONE,0.000 0,0.0000,0.0000,0.0000,0.0000,0.0000,"",0,0,0,0,0,00,0,0*ee072604 

I already sent a mail to Holybro support regarding the issue and requested them to update it.
If not we can add the work around to the px4 docs for now.

Fix coming: Fix coming: gps: request Unicore HEADINGA message by julianoes · Pull Request #22015 · PX4/PX4-Autopilot · GitHub

Give the PR a try and let me know if this works for you.

1 Like

@JulianOes I tried and its working fine now.

Right now gps frequency increased from 10hz to 15hz after the update. does it effect much?

That’s odd. I guess the frequency is only perceived to be more often because of the additional heading messages. I will look into this.

Hm, I just tried to reproduce this and for me the rate is 10 Hz. That’s with using lastest main and stock Unicore config as shipped by Holybro.

I tested again it is 10Hz now.

1 Like

Got this same problem, that the compass always starts up at 0dg north no matter what the direction of the drone is. Compass is alive, just not against true north.

Tried all kinds of solutions , also from this thread (uniheadinga com1 0.2 etc) , but cant make it work. (Px4 1.14 latest beta, also tested AP 4.4.1)
Px4 settings acc to holybro docs.

I also struggle to understand Uprecise 100%.
If i reset the um982 acc to holybro procedure, i seem to only see the datastream from com3 in the unit.
If i put in uniheadinga com1 0.2, it confirms OK but no changes seen in the datastream. (Ofcourse i saveconfig and reboot as well).
It connects to com3 automaticly it seems. If i set com1/2/3 to different baudrates, it always choose the baudrate for com3 at connect, which to me tells me the datastream is on Com3 only?

Can someone try to explain step by step how you reset at set the correct settings to get this unit to work as it is supposed to?
And perhaps explain me how the com1/2/3 behaves in Uprecise datastream, so i can understand this better?

I got 2 units here, same behaviour on both.

@O_G are you using RTK? if yes, is it fixed?
did you set all the parameters correct?

Not using rtk base, just need the H-rtk um982 gps onboard the drone as yaw/compass for magnetic interference reasons…

I have spent two long days of trying to get it working, using holybro docs settings for px4/Ardu spesific configurations, so i think i am using correct settings, but clearly not as it does not show true north…

Contacted Holybro support, but they only gave me theire reset procedure as a answer, even tho i clearly explained i had done that (even wrote the procedure to tell them what i did in my first email to Holybro)