Crash dump on SD card. Vehicle need servicing

Hello everybody,

I’m trying to update my Pixhawk 6c drone from v1.13.3 to v1.14, to use the xrce middleware instead of the rtps used previously.
I have been following these steps on the upgrade section of the version 1.14 page.
After flashing the px4 v1.14 firmware I am faced with the following errors on QGroundControl:

Screenshot from 2023-12-01 15-12-22

Screenshot from 2023-12-01 15-24-22

I have looked at this issue on github and this is the only thing that I could find. I have tried erasing all logs with qgroundcontrol. I have tried turning it on again but it shows the same error message.

Could you please help? Thanks in advance.

Did you try to reflash the firmware after connecting to QGCS. I think this should do the trick.

I tried re-flashing the stable v1.14 firmware with QGC. It didn’t work unfortunately.

try the stable version before this one if error occurs then there might be connection problem with any of the components especially check for motors.

I am already flashing the stable version. Could it be related that it is still using the parameters given with the v1.13? Like, should I maybe factory reset all the parameters?


Try it! But I am not sure if it will work.

I am also facing the same issue. Has anyone found the solution to this.

Have you tried removing the crash logs from the SD card? Or are there none?


Right now I don’t have the Pixhawk near me. I will try doing that in a week more or less.
I was thinking of backing up all the previous logs and then resetting the sd card to a default.
Thank you for the reply and happy new year!