Cannot Upload Firmware to Pixracer?

Hi all ,
I bought a new Pixracer yesterday and tried to upload the latest Firmware to Pixracer but failed!! I used command make px4fmu-v4_default upload to upload program to it and finally got error as following :

what happened to my Pixracer?

Ubuntu PC Environment:
gcc (Ubuntu 5.4.0-6ubuntu1~16.04.4) 5.4.0 20160609
arm-none-eabi-gcc (GNU Tools for ARM Embedded Processors) 5.4.1 20160609 (release)

From the screenshot you shared it looks like the upload worked. What makes you think it didn’t work?

hi @Nicolas ,
I’m not sure ,I had upload firmware to my pixhawks serveral months ago and If it run successfully , the message should end with [100%] Built target upload .

I don’t see an error in that screenshot.
Have you confirmed that the firmware running on the device is still old?

Hi @Nicolas ,
I used Qgroundcontrol to check the version of Pixracer aftering upload PX4-V4 Firmware and I got Unknown Version just as the following :

After flashing, you can check the firmware version, including the git hash, in a terminal using the ver command.

hI @Nicolas ,
Thank you for your advice! I have upgraded my pixracer to the latest version successfully.
Now , I’ve got an another problem:
The RGB LED on my pixracer is always flashing green even though I calibrated sensors ,radio ,power until no warning in Qgroundcontrol.
Is my pixracer working fine?

Yes, sounds fine. You’ll know there are problems if you try to arm or switch modes and you get warnings.

Hi @Nicolas,
I think my safety button is wired wrong or broken because I connect the safety button to my pixracer and pushed it and there is no reaction .
However, I can use these following commands to change flight mode or arm motors and the safety button changed mode at the same time.

roslaunch mavros px4.launch
rosrun mavros mavsafety arm  / disarm
rosrun mavros mavsys mode -c MANUAL / OFFBOARD / STABLIZED

any ideas?

What do you observe when trying to arm (in manual mode) with an RC? Depending on the airframe selected, the safety switch is not needed (i.e. off by default).

Hi @Nicolas,
Thank you for your reply!!
The airframe that i used is ix5-210 . i couldn’t find airframe related to ix5-210 in QGC ,so I choose Generic 250 Racer instead of Generic 210.
Eventhough I reconnected the Futaba S.Bus to my pixracer and recalibrated the joystick in mode 2 , I still couldnot arm the drone in manual mode . I saw the safety switch still blinking fastly that meant my drone was not ready to arm .
BTW , What parameter should I modify if I want to enable / disable safety switch?

The “Generic 250” frame has the safety switch bypassed/disabled. So your arming problems aren’t due to the safety switch.
Do you have telemetry to QGC when trying to arm? You should see a message telling you why it’s not arming.

Hi @Nicolas,
Thanks for your help and you’re right .
Today , I flew my drone indoor without safety switch successfully.
I used mocap system to feedback pose data and the performace was very good. However , I tried to use RC joystick to arm motors and there is still no reaction. I guess that I use the wrong way to arm the drone , because there was no warnning message in QGC when trying to arm motors.
Any idea?