Airspeed sensor FAIL


I have a pixhawk 4 by Holybro, and I have plugged the MS4525DO Airspeed sensor on I2C port but when connected to QGC it says that there is no airspeed sensor plugged.

I’ve tested the sensor with an Arduino to be sure it’s not fried (it’s not).

Do you have any idea how to fix it, is there some setting up to do?



Have you tried swapping the two middle wires?

Good luck.

I had a similar Problem with my pixhawk4. I have also a MS4525.
Try first trough the console (nsh) sdp3x_airspeed start -b x
x was in my case 4 (depends as far I understand which i2C port you are using.
If this is successful then ad on the sd card the file extras.txt and put the command above in this file.

@rollys: I’ve tried but no changes.

@Jakob_Strebel: I’ve tried but no success. Is there a way to read directly the I2C port and see if there is any input?

Tim, will be back (in front of a pixhawk not before the end of the month). I just looked in the Web about the sensor I was referring. The command I wrote is not for the 4525. But I am sure the 4525 works with the pixhawk4. We use the 4525 sensor in another Plane with the pixhawk4.
BTW: do you have a scope to see if you see any pulses on the date wires?

Jakob, I don’t have a scope but i’ve tried and plugged the sensor on a Arduino and it detects it. So I guess it works.

I’m still blocked on that issue.

Would there be a way to read all the inputs on the PX4? Or at least on the I2C port using the console?