Airspeed sensor is not found

Me and my collegues have slight problem with QGC and MP recognizing airspeed sensor. It was working completely fine but recently, after a long break, we wanted to flight our plane and calibrate airspeed sensor but neither QGroundControl nor Mission Planner could not find airspeed sensor. It is connected to I2C bus on Pixhawk unit.

Does anybody know what could be the problem ? Is it possible we have to somehow switch the I2C bus “on” in order to connect sensor or what else we can do ? If it is so, how can we do that ?

Cable from sensor to pixhawk is little bit longer but it did work before so we excluded this as a problem. We also measured voltage across ports and there was approximately 5V so the signal seems to go trought cable.

Thank you for your answers.

If you hadn’t done any upgrades or changed any configuration, have you tried reseating all of your connectors, i.e. unplug and plugin all cables from the Pixhawk to the I2C BUS to the airspeed sensor?

Good luck.

yes we even tried to re-connect everything and even to try new module on new pixhawk but still it doesnt lock on any GPS satellite . do we have to somehow start it or to switch it on ?
thank you

alrigth. this is silly. we tried to connect GPS modul to I2C splitter and now airpseed sensor and gps works. this is kinda funny. Does anybody know why it is so ? was it just because of bad connection between pins or it is my beginner mistake ?