1.14 Stable Holybro X500 V2 motors ramp down

I arm, and throttle up. Back two motors start spinning down. I am in manual mode. I am on 1.14. This does not happen in acro mode

I do the same test in 1.13.3 and do not see this issue

In 1.14, I reset ALL of the pids, and was able to take the x500 V2 off. Here is my question

Is this expected. Was the flight controller changed enough in 1.14 that I need to retune the drone…and if I do, does Holybro have that param file posted somewhere?

ok, so… I just took off in both position and manual mode for 1.14 stable.

the second i just throttled up for takeoff all motors came online and there was no issue.

However, it appears like i need to adjust the min pwm so that the motors dont just stop spinning. Because that behavior i have not seen before

You know what I bet it is… the default disarmed value in PX4 is now 1000 and the min pwm value is 1000 as well.

When i calibrate the ESC on the new 1.14 release it gives it 1000-2000 values, while 1.13 gave values from 900-2000.

So, now the ESCs dont spin when at 1000.

I bet, if I changed the disarm pwm value and recalibrated the ESCs things would work the same

Make sure to plug the ESCs in to FMU not IO ports



Looks like related to Default motor PWM configuration by MaEtUgR · Pull Request #21513 · PX4/PX4-Autopilot · GitHub.

Yes, this might be it. However, I think it was mostly because I had my motors mapped to I/O PWM out. On 1.13.2 it was fine since the old mixer was still there. But, once moved over to Dynamic Allocation I saw that the motors were mapped to PWM AUX. Weird that they even spun at all in 1.14.

But, my issue appears to have been solved by using FMU PWM Out after checking dynamic allocator settings.

@Andrew_Wilkins It looks like you use the X500v2 airframe type in QGC? That should default to use the Main (which is mapped to I/O PWM Out). So I am a bit confused.


  • I/O PWM OUT is mapped to Main
  • FMU PWM OUT out is mapped to AUX

Is that not the case? Curious on why you say make sure to plug ESC into FMU , not IO port?

Yeah mine was under “PWM AUX”. For the tests in the first videos I posted I was working with stable branches.

Today I was working with a branch of what I THOUGHT was off of 1.14 stable, so I assumed it could be applied towards the 1.14 stable discussion.

However, I did not create the branch. It could possible one of my guys who cut it for me branched off earlier than stable 1.14. And in that version the default was PWM AUX?

Or I am just going insane

I dont have my Pixhawk 6c with me right now, but I do have a modalai flight core, and I am seeing the same motor mappings

I suspect the branch I am working on is not from 1.14 stable.

I am still seeing those back two motors not spin if left at low throttle for an extended period of time (seen in the first 2 videos), but once I throttle up the drone takes off and there is not issue.

As Julian mentioned it might be because of the default PWM change from 900 to 1000. Not really an issue though

Yeah I do not know why my branch has the motors mapped to aux pins but it does

But, this is no one elses problem since its my branch