Opterra EFlite 40A ESC Won't Complete its Power Up Sequence

#1

I’m retrofitting an Opterra 2m Flying Wing with an mRo Pixhawk 1 using the Buffalo FX-79 Airframe with v1.8.0Dev firmware.

  • I first calibrated the ESC directly with the Rx to confirm MAX-MIN endpoints.
  • Power cycled and it emits 1 beep, then 3 beeps for 3S, then the musical tones to confirm it’s ready for use.
  • Motor responds to full range of throttle.
  • Then used the ESC Calibration in QGC for good measure.

After power cycling the battery, the ESC will beep once, then 3 times to confirm 3S battery but will not go any further, as if it senses the throttle is not at minimum? I have a suspicion it has something to do with the ESC where it’s looking for some other lower PWM signal to allow it to continue its bootup sequence. I was hoping some might have an idea on how to resolve this.

@dagar @JulianOes any thoughts?

Thanks.

#2

@rollys I think that’s expected until you press the safety button or you configure the DISARMED value using the parameter, e.g. https://dev.px4.io/en/advanced/parameter_reference.html#PWM_MAIN_DIS4.

#3

I set it to 835 which was the setting of an Opterra 1.2 that had an EFlite ESC.So that did it but now when I arm it, the motor starts spinning at idle. What do I need to adjust to change that so it only starts to spin when the throttle is raised?

Thanks.

#4

For multicopter it’s a featuer that the prop is already spinning. For fixedwing you might not want that indeed. In this case your PWM_MIN should be equal to PWM_DISARMED.

Try this one: https://dev.px4.io/en/advanced/parameter_reference.html#PWM_AUX_MIN4

#5

Why PWM_AUX_MIN4 when the ESC is plugged into MAIN4? Besides, the parameter is not available. In any event, I matched all PWM minimums and it’s still doing it. Any other thoughts?

Thanks.

#6

Sorry, yes use whatever param makes sense for your configuration.

Another thought, try this:
https://dev.px4.io/en/advanced/parameter_reference.html#FW_THR_IDLE

#7

I changed it to 0% and it still spins. Any other thoughts?

Thanks.

#8

Not really. You could check with the pwm command in nsh to see what the outputs are. Maybe that gives you some insight.

#9

I’m not a coder or such so I wouldn’t know what to look for or syntax to use . I may just ditch this whole thing or change ESC. Thanks for all your help.

#10

What I mean is to use mavlink_shell.py which gives you the nsh> (NuttShell) and you can use the pwm command there.

https://dev.px4.io/en/debug/system_console.html#mavlink_shell

https://dev.px4.io/en/middleware/modules_command.html#pwm

#11

Quite honestly, that’s way over my head. I thought maybe it was the ESC and its programming but I tried it on ArduPlane and it works like normal. Is there something in the FX-79 Wing mixer that somehow overrides FW_THR_IDLE value, even when it’s set to zero?

Thanks for your help.

#12

Right, I understand. I’d have to try to reproduce this on my hardware here. I’ll put it on my todo list to check.

#13

FYI… I just tried it with another ESC and it seems to work with that so this might be unique to the EFlite ESC. But weird though that it works fine in ArduPlane. Oh well, thank you very much for all your help. Do let me know if you find a solution.

1 Like
#14

@dagar @LorenzMeier I’m getting desperate here. I’ve got an unsafe situation that @JulianOes has been kind enough to assist me with but we have not resolved the issue. I decided to get a different ESC but I’m getting the same results. I’ve tried the exact same setup with ArduPilot and have no issue with it. The motor stays stopped when armed and it only starts to spin when the throttle has moved about 10%. I’ve attached the params file (just change the extension back) and the last 2 logs as I bench test the setup. Your assistance is highly appreciated.

mRo v1_8_0Dev FX79 Wing.stl (22.5 KB)
log_19_2019-2-16-06-29-02.stl (292.2 KB)
log_20_2019-2-16-06-29-06.stl (130.0 KB)

Thanks you very much,

#15

I revamped the whole setup and started from scratch. I even replaced the ESC with a new ZTW Beatles 60A that was calibrated via the Rx. I loaded ArduPlane then after the reboot I loaded PX4 v1.8.2 Stable and chose Generic Flying Wing for the airframe and went through a complete calibration and setup procedure. In stock settings, the ESC wouldn’t respond. So the following changes were made:

PWM_MAIN_DIS4 = 900 (from -1)
FW_THR_IDLE = 0 (from 15)
RC1_MIN = 900 (from 0)
RC1_TRIM = 900 (from 0)

The ESC now makes its normal boot up tones but as soon as you Arm, the motor starts to spin! Attached is the param file (just change extension back to params).
Thanks.

022119 Opterra mRo v1_8_0Dev SkyDroid Generic Wing.stl (22.8 KB)

#16

That’s annoying. And in what mode are you arming?

#17

Tell me about it. I spent a week and a half and lost a weekend to maiden. I tried both Manual and Stabilize. Anyway, I went back to start from scratch again but this time only changed PWM_MAIN_DIS4 = 900 and FW_THR_IDLE = 0 and it worked! So now I’m able to arm and the motor doesn’t spin until about 10% up on the throttle.

Thx.

#18

Ok good. I think these 10% are probably a dead band for throttle. It’s likely that is some default in PX4.