"Your vehicle is not responding" please reconnect

Anyone here came across same or similar situation?

This means that there is no mavlink traffic coming from Vehicle->QGC on the comm link.

Can mean:

  • Firmware is hosed up somehow
  • Comm link is bad
  • Bad USB cable
  • Your are connected over USB to a Cube Orange/Yellow which is a composite USB device which QGC doesn’t handle correctly yet. In that case you can ignore the error and things should still work fine.
1 Like

this is screenshot from commlink manager

Still the same , no changes, but it works with mission planner

Are you running some sort of custom firmware. There are heartbeats coming from a component using the id MAV_COMP_ID_USER1 but not heartbeats from a MAV_COMP_ID_AUTOPILOT1 component which is what QGC needs to understand there is a vehicle on the other side of the connection.

No , We did not do anything with the firmware, it worked perfectly well past week .
It is working currently with mission planner as well. there is this previous error "vehicle is not responding when connected to QGC, although the updating of firmware is going smooth "
We tried running QGC on Ubuntu and then we got an error "error on link ttyACM0,access denied. So we did a quick check on
-all comm ports and drivers
-USB cable
and nothing changed

You need to futz with modemmanager to get usb connect to work on linux.

What kind of board are you running and what exact firmware is on it?

1 Like

Ok so you mean, I got to check with modem manager and check usb connections etc?
I am using Pixhawk ( 2.4.8) by Hex , running px4 firmware version 1.11

Look here https://dev.px4.io/v1.9.0/en/setup/dev_env_linux_ubuntu.html for Permission Setup and modemmanager. QGC should tell you at boot though is these are wrong.

ModemManger was not installed .

I did the flashing to Master Dev version as well , but no change.