Firmware Uploaded, but Waiting for Vehicle Connection

Hey all,

During initial setup, my QGroundControl (from installer, not built from source) was successful in detecting my PixHawk Cube and updating the firmware by rebooting. However, I’m not able to connect to the device.

I’m (unfortunately) using Windows. I can see “Legacy FMU” on my COM5 port in Devices and Printers. I’ve tried to manually add Comm Links. I’ve added it on that same COM port, and I’ve tried a few different Baud Rates. In devices and printers it says it was at 9600, but that didn’t work. I’ve also tried 115200 which seems to be the board default.

Additionally, when I connect to USB via the Buzzer+USB plug, I get incessant beeping, which I found the code for here:

This site says that my board seems to be in Program PX4IO mode, described as “starting to program PX4IO,” which I haven’t found any useful documentation for. I left it for ~20 minutes beeping (must to my neighbor’s dismay) to see if it was programming itself.

Thanks in advance for any help

You shouldn’t need to futz anything in the OS. You should just have to connect over usb. Make sure you have a good USB cable and if having problem go directly to the computer with usb, not through a separate powered usb thingy.

You could try using a daily build which has better Cube flash support but if you were able to flash and got no errors then the firmware should be on the board correctly since there is a verify step after the flash. Sounds more like a firmware problems.