Error on link /dev/ttyACM0, cant talk to pixhawk

I seem to be unable to connect to my pixhawk using qgroundcontrol. I do not believe it is a bad board because when I flash it with the apm stack there is no problem connecting. I am on a laptop, running ubuntu 14.04. I have also tried connecting with a windows computer which was unsuccessful.

I have tried flashing both stable and master. I installed Qt to opt and got qgroundcontrol 2.8 up and running and haven’t had any luck. I have downloaded the newest version of qgroundcontrol as both the app image and the tar and have had zero luck with both. I have also unsuccessfully tried the daily build of qgroundcontrol.

I have tried flashing it with using make px4-fmu-default from github. I have tried flashing it with out project’s transmitter free version.

I can not seem to get qgroundcontrol to talk to this pixhawk.

When I try to connect to /dev/ttyACM0 in the COMM LINKS tab i get:

Error on link /dev/ttyACM0. Error connecting: Could not create port. Permission error while locking the device

There are a few other posts I’ve found that have seen this error:


https://gitter.im/mavlink/qgroundcontrol?at=56973e34a03e28ad1ade9c40

In the gitter link, a debugging qgroundcontrol for linux page is mentioned. However I cant seem to find the page qgroundcontrol.com :confused:

I am a member of the dialout group and have removed modemmanager.

I have powered the pixhawk externally, allowed it to boot, then connected it via usb with no connection.

Any help would be appreciated.

That is almost always some sort of Linux setup error. QGC can get write access to the port. Hopefully some linux folks can help you out. The linux page referenced no longer exists.

I have also tried to connect using a lab-mate’s windows machine and had no luck. I have not tried writing to it from the windows machine. I will try that

I missed the windows connect. Also the QGroundControl 2.8! That version is way old. Use a newer version. Stable is 3.0.

i have tried stable and master

I came across a post during my journey to fix this that claimed 2.8 would resolve this issue.

I have had this problem with every version of QGC i have tried.

I still haven’t written to the pixhawk from a windows computer. That’ll be tomorrow morning once windows machines are back in lab.

Ive tried to flash it with a windows and a mac. Both attempts were not successful.

this is what QGC logging is telling me

LinkManagerVerboseLog: -----------------------------------------------------
LinkManagerVerboseLog: portName: “ttyS4”
LinkManagerVerboseLog: systemLocation: “/dev/ttyS4”
LinkManagerVerboseLog: description: “”
LinkManagerVerboseLog: manufacturer: “”
LinkManagerVerboseLog: serialNumber: “”
LinkManagerVerboseLog: vendorIdentifier: 32902
LinkManagerVerboseLog: productIdentifier: 7229
LinkManagerVerboseLog: -----------------------------------------------------
LinkManagerVerboseLog: portName: “ttyACM0”
LinkManagerVerboseLog: systemLocation: “/dev/ttyACM0”
LinkManagerVerboseLog: description: “PX4 FMU v2.x”
LinkManagerVerboseLog: manufacturer: “3D Robotics”
LinkManagerVerboseLog: serialNumber: “0”
LinkManagerVerboseLog: vendorIdentifier: 9900
LinkManagerVerboseLog: productIdentifier: 17
QGCSerialPortInfoLog: Found PX4 FMU V2
QGCSerialPortInfoLog: Found PX4 FMU V2
LinkManagerVerboseLog: Skipping existing autoconnect “/dev/ttyACM0”
LinkManagerVerboseLog: -----------------------------------------------------
LinkManagerVerboseLog: portName: “ttyS4”
LinkManagerVerboseLog: systemLocation: “/dev/ttyS4”
LinkManagerVerboseLog: description: “”
LinkManagerVerboseLog: manufacturer: “”
LinkManagerVerboseLog: serialNumber: “”
LinkManagerVerboseLog: vendorIdentifier: 32902
LinkManagerVerboseLog: productIdentifier: 7229
LinkManagerVerboseLog: -----------------------------------------------------
LinkManagerVerboseLog: portName: “ttyACM0”
LinkManagerVerboseLog: systemLocation: “/dev/ttyACM0”
LinkManagerVerboseLog: description: “PX4 FMU v2.x”
LinkManagerVerboseLog: manufacturer: “3D Robotics”
LinkManagerVerboseLog: serialNumber: “0”
LinkManagerVerboseLog: vendorIdentifier: 9900
LinkManagerVerboseLog: productIdentifier: 17

i deleted the custom port in the COMM LINKS page and got the following output

LinkManagerVerboseLog: -----------------------------------------------------
LinkManagerVerboseLog: portName: “ttyS4”
LinkManagerVerboseLog: systemLocation: “/dev/ttyS4”
LinkManagerVerboseLog: description: “”
LinkManagerVerboseLog: manufacturer: “”
LinkManagerVerboseLog: serialNumber: “”
LinkManagerVerboseLog: vendorIdentifier: 32902
LinkManagerVerboseLog: productIdentifier: 7229
LinkManagerVerboseLog: -----------------------------------------------------
LinkManagerVerboseLog: portName: “ttyS4”
LinkManagerVerboseLog: systemLocation: “/dev/ttyS4”
LinkManagerVerboseLog: description: “”
LinkManagerVerboseLog: manufacturer: “”
LinkManagerVerboseLog: serialNumber: “”
LinkManagerVerboseLog: vendorIdentifier: 32902
LinkManagerVerboseLog: productIdentifier: 7229
LinkManagerVerboseLog: -----------------------------------------------------
LinkManagerVerboseLog: portName: “ttyS4”
LinkManagerVerboseLog: systemLocation: “/dev/ttyS4”
LinkManagerVerboseLog: description: “”
LinkManagerVerboseLog: manufacturer: “”
LinkManagerVerboseLog: serialNumber: “”
LinkManagerVerboseLog: vendorIdentifier: 32902
LinkManagerVerboseLog: productIdentifier: 7229
LinkManagerVerboseLog: -----------------------------------------------------
LinkManagerVerboseLog: portName: “ttyS4”
LinkManagerVerboseLog: systemLocation: “/dev/ttyS4”
LinkManagerVerboseLog: description: “”
LinkManagerVerboseLog: manufacturer: “”
LinkManagerVerboseLog: serialNumber: “”
LinkManagerVerboseLog: vendorIdentifier: 32902
LinkManagerVerboseLog: productIdentifier: 7229
LinkManagerVerboseLog: -----------------------------------------------------

the amber light on my pixhawk is blinking at 4Hz. this indicates that :4Hz: No FMU Input (e.g. no controller app loaded at startup). I will try flashing it with a vehicle specific build .

The arming button and main light on my iris are flashing red at around 4Hz. This seems to indicate an arming error.

Success!!! I pulled out the sd card and wiped it. Then I flashed the pixhawk again using the latest app image QGC.

There was some mention in the gitter post linked above of messing with telem2. I was in the process of setting up an odroid as a companion computer when i lost contact.

During the connection I had reconnected the telem2 port to the radio that came with the pixhawk. Maybe this is relevant?

I doubt it was a telem2 problem. More likely your sd card had gone wonky with the sd card wipe fixing the problem.