Weather vane function not working ("Standard VTOL configuration")

Dear passionated VTOL pilots,

my plane, which I posted fotos earlier, works fine now, also Auto-Mission. As long as my landing waypoints are directly into the wind. Problems start if my landing direction is sideways to the wind. The plane trys to keep it’s heading, and doesn’t weathervane, as I would like it to. Means the motors are fighting against the wind.

Also if I fly stabilized-mode, fly above my head, and push by hand on the tail slowly, the plane always tries to get back to the original heading.

I tried to get weathervaning running by adjusting different value in:
Default is 0,15, I also tried 0, 0.5, 1.0. Couldn’t notice any difference.

Does it have something to do with the waypoint types?
In my missions I use the waypoint types:
“VTOL takeoff and transition”
“VTOL transition and land”
In both there is defined a heading angle. Unfortunately I can’t set it to “free moving”. Or is there any hidden parameter?

I’m thankful for any advice.

In general: big thumbs up to the PX4 developpers! Amazing job you did!!

Thank you!
Best regards,


Do you have a log so i can check?
The weathervane scale is the percentage of yaw it tries to apply during weathervaning. so 0.15 is 15% and 1.0 is 100%

If it is still too much you can try 0.05 for 5% or even 0.01

It might be that you have not enabled weathervane during takeoff and/or land, those are separate params

Dear Sanderux,
thanks for your fast reply, where is the parameter to enable/disable weathervane during takeoff and land?
Didn’t find it in the params. Is it in the waypoint settings?

Will check for a logfile when I’m back at home.


The params are VT_WV_LND_EN, VT_WV_LTR_EN and VT_WV_TKO_EN
They are all listed under vtol params

Dear Sanderux,

thanks, I found the parameters hidden in “Mission”, at least the first 2:
VT_WV_LND_EN and VT_WV_LTR_EN, I enabled them both for todays flight. And set VT_WV_YAWR_SCL back to default 0,15.
The 3rd one VT_WV_TKO_EN doesn’t exist in my version.
Currently I use firmware version 1.4.4 from august 2016, I guess I have to update to the latest version.

The weathervane worked now for the first time during landing!
Although the plane looked nervous after backwards hovering.
Here a video of todays flight (auto-mission):
Wind came from the left ~10-15km/h.

Logfile of this flight:

This is an older video from 1 week ago, same mission, but without any wind:

Have a nice evening!


Setting MPC_THR_MIN to 0.25 will likely help against that behavior. It is induced by the wind catching under the wing and the multicopter is then trying to fight lift.

Thanks for your advice, will test this!