Plane not climbing to waypoint

I fly a Pixfalcon in a Z84 flying wing without airspeed sensor. If the first waypoint in a mission is a takeoff-waypoint, it’s climbing like a rocket to get there. If the first waypoint is a regular waypoint at, say, 80 meters, and I switch to mission-mode at, say, 40 meters, it only increases throttle a little, pitch is increased, but i doesn’r climb due to the low airspeed. After a few seconds it cuts the throttle, glides straight forward and after a few seconds more it increases pitch and throttle again, but throttle is not close to max, and the pattern is repeated. Throttle max is set to 100 percent.
Any ideas skyld be highly appreciated.

This sounds very similar to the post I made yesterday. In fact it sounds similar to how one of our aircraft crashed twice. Can you look at your flight log and check the GPSP - you might find it goes to 0 or some value you don’t expect. We have also had success flying with a takeoff waypoint, but flying with a regular waypoint seems to intermittently cause this problem.

@dagar I’ve created an issue to track this:

@Thrane @Anton_Rothwell could you post your logs?

I’ll take a look at this today.

Edit: I thought a log had been posted but I was wrong. @Thrane @Anton_Rothwell Please upload the log so we can help you.

I would guess @Thrane’s issue has more to do with fw_pos_ctrl/TECS behavior without an airspeed sensor and possibly tuning.

If you post your log I’m happy to take a look, but out of curiosity why don’t you have an airspeed sensor?

Having family visit this weekend! Will upload log ASAP.
No airspeed sensor: Wanted to start out simple, basic in itself has steep learning curve. And read that you could do without AS sensor, Pixfalcon estimating wind. But on the other hand, I have thought, that of course an AS sensor would be best. So I thought about getting one. Where would you guys buy one in Europe. Have found it a few places, but could you recommend a dealer?
But actually, except from the problem described in these posts, my Z-84 actually flies very well even without the airspeed sensor.
By the way, my Z-84 behaves in the same manner in zero wind conditions where you would think that wind estimation would be easier.

Managed to some testing today to get some logs from flights where my problem was very evident. Unfortunately I don´t know how to uoload the log itself, so here is only a screenshot from LogMuncher. I quess I will have to ask for your help with uploading the log itself

The images here is from a flight with the first waypoint beeing TAKEOFF and the rest regular waypoints with some altitude changes. It can be seen, that the plane climbs at 100 % trust toward the TAKEOFF waypoint (after a handlaunched, manual start). After that, and after a planned descent, it climbs towards a waypoint at less than full throttle, but makes it there in the right altitude because there is some distance frem the lower to the higher waypoint. Note pitchangle beeing higher (although I don´t understand the numbers) in the low throttle waypoint to waypoint climbs than during takeoff. In the third climb, starting at around 15:22:50 the distance to the higher waypoint is shorter than before. The plane again climbs with high pitchangle and low throttle. At around 15:23:10, it “gives up”, lowers the throttle to 10 % for a few seconds and descends a little, then throttles up to around 60 percent again and actually makes it to the planned altitude.
This - admittedly simple - analysis is based on looking at graphs at LogMuncher, which shows the same as I could see on the plane during the flight.

The next images is from a flight where the first waypoint is a regular waypoint (not TAKEOFF).

The waypoint is at 90 meters altitude relative and fairly close to the launch point. In the last half of the auto-part of the flight, you see the sawtooth pattern of altitude and throttle. When looking at the plane during its attempt to climb it was obvious, that the angle of attack was way too high for climbing without full throttle.
Looking forward to hearing from you.

It does look different to my log. Your gpsp seems to maintain its set point from the start. Oscillation is probably due to lack of airspeed sensor. We’ve flown without a working sensor before and it oscillated pretty badly resulting in a flight that was terminal.

Hmm, maybe the problem could be solved with an airspeed sensor. But I think there is another problem in the settings somewhere: It climbs perfectly towards a TAKEOFF waypoint without airspeed sensor. So it is actually capable of performing a correct climb.

You can just share the logmuncher link as it allows downloading the raw log.

The takeoff waypoint is special. It forces full throttle and >= 10 degree pitch for climbing out.

I’d like to take a look at your log to understand what TECS is doing during the throttle pulsing. It’s likely something we can improve, but right now you’re still going to have a much better experience with an airspeed sensor. As far as I know most PX4 fixed wing users and developers have airspeed sensors so our support for flying without is poorly tested.

Thanks for your reply, Dagar. I´m sorry for this late reply. Work tends to take an unreasonable amount of time, that should have been spent flying and posting here! Anyway, an airspeedsensor is headed my way in the mail, but I would still very much apreciate if you would take a look at my logs. Links below.
First flight:
Second flight:

Sorry I completely missed your response, discuss doesn’t seem to notify like I’d expect. I’ll have time to go through your logs this weekend.

The second flight looks terrible.

I’ve created an issue on github.

@Thrane it’s the land detector causing problems. So first of all lower the LNDFW_* params so that landing isn’t accidentally detected.

As for the poor climb, try decreasing FW_T_THRO_CONS and FW_P_LIM_*.

Thank you very much, Dagar. As you advised, I bought an airspeedsensor and have yet only had the chance to test it once. Clearly, it flies much better with this sensor. Så for now, my problem seems to be solved. I will be happy to modify the settings you mentioned and test without the sensor, if it can be of any help in your work. Please let me know if you want me to test without the airspeed sensor.