VTOL - FWD Thrust Motor Not Working Pixhawk 4

#1

Forward thrust motor (Aux 5) spins to full throttle when vehicle is armed.No control of the motor until battery is unplugged. All other servos and multicopter motor operating correctly.

Forward thurst motor in AUX 5 slot on a Pixhawk 4 with Power Management Board.

Fun Cub airframe settings:
MOT_SLEW_MAX 0.00
PMW_AUX_DIS5 950us
PMW_AUX_FIAL5 -1us
PMW_AUX_MAX5 -1us
PMW_AUX_MIN5 -1us
PMW_AUX_REV5 Disabled
PMW_AUX_TRIM5 0.00
PMW_MAX 2000
PMW_MIN 1000
PMW_RATE 400hz
PMW_SBUS Disiabled
THR_MDL_FAC 0.00

Not sure what’s going on???

#2

Hi Tim

Does this only happen when you toggle the transition switch to go from multicopter to fixed-wing mode? Because then this would be the normal behavior, as the thrust motor will go to whatever you set in ** VT_F_TRANS_THR** and keep that till either VT_ARSP_TRANS (if you fly with airspeed not disabled) or VT_F_TR_OL_TM (if airspeed is disabled) is reached.

If it keeps being at full throttle after the transition is supposed to be finished we need to look deeper.

#3

The problem happens as soon as I arm the aircraft… I have the vehicle in multicopter, and flick the arm switch on my Tx. The hover motors spin to idle rpm ready for flight, but the FWD thrust motor activates immediately upon arming and spins to full RPM. I can disarm the vehicle and the hover motors shut down but the FWD thrust motor does not respond at all maintaining high speed RPM until BATT is disconnected.

Airspeed is disabled… below are screenshots of the above VT_F setting you mentioned.


Really appreciate your input!
Tim

#4

Let’s check the PWM outputs of the AUX: please enter in the console:

pwm info -d /dev/pwm_output1

and share a screenshot.

#5

Or actually, first try to make a ESC calibration:
https://docs.px4.io/en/advanced_config/esc_calibration.html

#6

Re-calibrated the ESC’s
Below is the screen shot for the pmw outputs…
Not sure if this helps (or my be the problem, but using a Spektrum DX6 (6 channel)… on the Tx the channel 5 is setup as my arming switch, and channel 6 is my threeway switch for flight modes.


#7

Sorry, forgot to specify that you should enter the command while you are encountering the wrong behaviour of the motor, so while you have the vehicle armed, the throttle stick at zero and not in transition mode.

#8

Did the motor still spinn up to max throttle after the ESC calibration?

#9

Still happening… FW motor spins to full RPM when I arm the vehicle in Multicopter flight mode.

New screenshots uploaded:
First is while the vehicle is armed…hover motors spinning at idle, but FW motor at full RPM.
Second is after disarming the vehicle… hover motors stop but the FW motor continues at full RPM until unplugged.

Not sure if this helps (or my be the problem, but using a Spektrum DX6 (6 channel)… on the Tx the channel 5 is setup as my arming switch, and channel 6 is my threeway switch for flight modes.

#10

The PWM signal of AUX5 is at an correct value of 1000, which is the setting for no rpm for a normal ESC. It seems to me as though your ESC is calibrated wrongly, as in your case it goes to full throttle instead. If the calibration over px4 does not help you should proceed with the steps explained in the ESC manual for calibration using a RC ( normal procedure is to plug in battery with throttle stick at max, then go to min and max again I think, but check that).

If you have an other ESC close by just give it a shot with that one I’d recommend.

#11

Hi Sfuhrer
Finally figured it out!!!
The hover motors esc’s were BLheli and the forward thrust motor was a simonK. Together they wouldn’t calibrate properly. Switched it to a BLheli esc and re-calibrated… everything is working perfect now!. Your comment on “calibrated wrongly” is what made me think of it.
Thanks for the time you put into helping me. Much appreciated!!!