Pixhawk 4 Motor/ESC Arming


My setup is as follows,

Hardware: F450 Frame, 2216 880kv T-Motor, 600Hz Air 20A ESC, Pixhawk 4, Power Management board PM07, Pixhawk 4 GPS Module. I’m also using a Turnigy 9X for RC.

Wiring: Motors connected to ESC, ESC connected to I/O M1 - 4 of the PM07, and PM07 is connected to Pixhawk as per https://docs.px4.io/v1.9.0/en/assembly/quick_start_pixhawk4.html - Recommendation for ‘copter’.


  • I’m using QGroundcontrol, I connected the pixhawk
  • I used QGC to flash the pixhawk with 1.9.2 instead of 1.9 that was there already.
  • In Airframe I selected DJI Flame Wheel F450 and rebooted the system.
  • In Sensors I have done the Compass Calibrations rebooted and finish the rest of the Sensors calibrations.
  • In Radio, this was a bit tricky but I managed to calibrate the Turnigy 9x, It’s not recognising the full 8/9 channels however I do have 7 Channels working.
    * In Additional Radio setup, all the parameters are unassigned after my calibration.
  • In Flight Modes, I’m using the single channel modes,
    1. Mode Channel is assigned, however I only assigned two Flight Modes [Manual, Hold]
    2. Arm switch Channel is also assigned
    3. Everything else is not assigned yet
  • In Battery, I have set the battery parameters, then calibrated the ESC, it said it was completed.

After much trying I think I managed to understand the arming sequence as documented here, https://docs.px4.io/master/en/advanced_config/prearm_arm_disarm.html

I currently have CBRK_IO_Safety set to 22027 to remove arming sequence out of the equation just incase that’s where it fails every time.

My start sequence is as follows,

  • Reset Transmitter’s switches and dials to default
  • Throttle Down
  • Manual Flight Mode Switch On
  • Power Transmitter
  • Plug Battery in
  • After much start up tunes playing, LED flashing green ( I assume that means it thinks it’s armed? )
  • Throttle Up
  • … and nothing happens

The only thing I observed is that the Motors/ESC are constantly beeping, I checked the ESC Manual and it said rapid beep might be because of ‘the throttle stick is not at the bottom position’, however it is, I tried to recalibrate RC, then recalibrate ESC and nothing.

Can anybody kind enough to shed some light at what am I missing here?

Thanks in Advance.

Just an update,

I have managed to get the Motors working. Initially I thought it’s to do with the PWM_Min and PWM_Max as they do not seems to be changing and I started questioning if the ESC Calibration are even working.

As I stripped my setup apart to manually calibrate the ESC to my transmitter, I had a last glance at my wiring, and it turned out that my I/O PWM Out from the PM07 board was connected to the FMU PWM In and similarly for the FMU PWM Out to I/O PWM In.

I defaulted all parameter as I stripped the setup and built it again, and did all the calibrations again, and now the motors instantly spins after arming even at 0% throttle on my transmitter.

Recalibration the ESC doesn’t do anything, the PWM_MIN and PWM_MAX don’t seem to be effected by ESC recalibration. I tried Radio recalibration too. I may need to manually play with the gain parameters.