VTOL autonomous transition

I got the VTOL duo tailsitter firmware loaded on my pixhawk and I have successfully done a hover test on my plane in manual mode. I am using a foam board plane that I designed called MantaRay which I am hoping to open source soon. I have tested transitions on the ground and they appear to work well and I will be going to the field to test it live soon. My question is does the system currently support a sequence such as autonomous take-off in multirotor mode with autonomous transition into plane mode and then run a mission? I know mission planner quite well but I am new to Q ground control so I am not sure about some of the details.



great to hear that you got stuff working. When are you planning to for a test flight?
I might have a potential fix which should make the behaviour of backtransition better. Would you be interested in testing that?


I tried a full test flight yesterday which went badly. Hover worked OK but when I switched into flight mode it rolled onto its back and came down. A post flight diagnostic revealed that the motors were spinning up at different rates giving significant differential thrust. I did sync the ESC’s and at low throttle and high throttle they are even but mid throttle they are not. I am swapping the ESC’s today to resolve this and plan to fly again tomorrow.

I would absolutely be interested in trying it. Please let me know your suggestion.

In case you are interested here is my test flight for hover in my backyard. The plane is something I designed and laser cut out of dollar tree foam. My hope is to get this all working and then open source the planes design.



Hi Fred,

looks nice! I’ll do a PR today in the afternoon and will let you know. Are you fine with flashing a PR or do you want me to send you binaries?

we are also doing this test,hoping to communicate with you the following work

i also came across this problem that it rolled onto its back 。I observe that if i switch the fw mode but not get succeed,the vehicle is in stabilized mode of multicopter and i cannot control it。 so,i am wondering that how do you solve this problem。

I also encountered this problem, four rotor unlocking four OARS did not turn together, I also tried ESC calibration, but did not succeed.Can you tell me how you solved the problem?