Video stream into QGC

Hi another day = another issue and questions :slight_smile:
I would like to ask for help with streaming a vide from simulated camera into QGC.
I believe there is no plugin to stream a video while using new Gazebo with ubuntu 22.04 or is it? Or can I somehow enable it with x500_vision?
But I am unable to stream any video with old gazebo neither. I tried to use following docker image GitHub - JonasVautherin/px4-gazebo-headless: An unofficial Ubuntu-based container building and running PX4 SITL (Software In The Loop) through gazebo. with this command, but still I am unable to see anything in QGC. I did set the QGC camera port to the one from the image and still nothing.
I have my own docker image and I am able to connect and flight the simulated drone from it, but again I am unable to get any video stream (using Gazebo Classic Vehicles | PX4 User Guide model)
I am not sure how to understand and how to use following Simulation | PX4 User Guide
based on instructions (Gazebo Simulation | PX4 User Guide) I should see Video ON/Off button in gazebo GUI, but I dont.

What can be wrong here?

Can anyone help pls?

1 Like

Well, I have update if anyone intersted :slight_smile:
I have installed gstreamer1.0-tools on my local machine and I am able to see the Vide: On/Off button finally. But still no stream into QGC. I am on ubuntu 22.04 and the simulation is running on ubuntu 20.04 and appearently there is a change in gstreamer library between those two so I am not sure if it is compatible now or not.

I have found video with working camera and stream and gimbal simulation Simulated Workflows using Software-In-The-Loop Simulations — PX4 Developer Summit Virtual 2020 - YouTube
Can anyone help me to understand how to achieve this state? It seems it shall be ready in 2020. But I am unbale to find anything about how to start it.

It seems there needs to be reverse proxy service created to forward the data from docker port to QGC port.

ok, the solution is, that in the jinja file for model it needs to say for gst_camera_plugin udpHost = host.docker.internal and it starts to work :slight_smile: