Ubuntu 18.04,gstreamer can't be installed,so gazebo video steaming doesn't work

Hello,under ubuntu 18.04,when following this link

https://dev.px4.io/en/simulation/gazebo.html

to install gstreamer,I got this error:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gstreamer1.0-python3-dbg-plugin-loader : Conflicts: gstreamer1.0-python3-plugin-loader but 1.14.1-1~ubuntu18.04.1 is to be installed
 gstreamer1.0-python3-plugin-loader : Conflicts: gstreamer1.0-python3-dbg-plugin-loader but 1.14.1-1~ubuntu18.04.1 is to be installed
E: Unable to correct problems, you have held broken packages.

then

make px4_sitl gazebo_typhoon_h480

this error will come up:

INFO  [px4] Startup script returned successfully
pxh> [Wrn] [msgs.cc:1852] Conversion of sensor type[sonar] not supported.
[Err] [Plugin.hh:180] Failed to load plugin libgazebo_video_stream_widget.so: libgazebo_video_stream_widget.so: cannot open shared object file: No such file or directory
[Err] [MainWindow.cc:2094] Unable to create gui overlay plugin with filename[libgazebo_video_stream_widget.so]
[Wrn] [msgs.cc:1852] Conversion of sensor type[sonar] not supported.
INFO  [ecl/EKF] EKF aligned, (pressure height, IMU buf: 22, OBS buf: 14)

gazebo simulator worked,but video streaming doesn’t,and it seems like a gstreamer install problem,anyone know how to fix this problem?Thanks.

Yes this might actually be broken. What exactly do you need or are you trying to do?

@JulianOes,thanks,I want to know how to fix this problem to make gazebo video streaming work.

Yes that would be nice, I didn’t get very far either though debugging gstreamer dependencies. You’ll have to dig through the CMakeLists.txt files see how it all should work.

Did u find a solution?

+1 same issue here when installing gstreamer on Ubuntu 18.04 LTS:

Reading package lists...

Building dependency tree...

Reading state information...

Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created

or been moved out of Incoming.

The following information may help to resolve the situation:

The following packages have unmet dependencies:

 gstreamer1.0-python3-dbg-plugin-loader : Conflicts: gstreamer1.0-python3-plugin-loader but 1.14.5-0ubuntu1~18.04.1 is to be installed

 gstreamer1.0-python3-plugin-loader : Conflicts: gstreamer1.0-python3-dbg-plugin-loader but 1.14.5-0ubuntu1~18.04.1 is to be installed

E: Unable to correct problems, you have held broken packages.

To follow up here:

Presumably you don’t need to install gstreamer1.0 but only libgstreamer1.0-dev and maybe some of the plugins, e.g. gstreamer1.0-plugins-good, gstreamer1.0-plugins-bad, gstreamer1.0-plugins-ugly.