Unstable while hovering and Yaw when takeoff


I have a quadcopter and have added foldable arm joints to it and tried to fly it but seems unstable and it looses altitude while hovering for for milli second and recover where you can hear the thrust change while doing this. Also I tried to use QGC takeoff option to see how it hovers there but when I tried it drone took off but with a 90 degrees YAW to the left and again was not 100% stable while hovering! I inspected the drone afterwards found out that few arms are has play when I twist arms with moderate force where motors change angle, the twist looks like 3mm each direction.

I updated the firmware before that test to the current latest stable release. Also my log is below


I’m using blue cube FC and HERE3 GPS


The only thing that sticks out during this flight is, that two of your motors uses significantly more power compared to the other two. There can be multiple reasons for this, bad ES, bad wiring, different ESC/motor, and so on. But in your case, I would think it is because the motors gets tilted, with the 3mm twist you say you can detect yourself. Any small change which causes the motors to not be horizontal can causes these changes. So fix your arms and I think you should be good.

Hi Madsen,

Thank you for your reply. Could you highlight or show me the graph or motor number that has more consumption.

I’ll fix this and see how it goes but how’s the vibration and tuning? And what about the YAW issue?


Sorry for the slow reply, haven’t been online for a couple of days.

Here you can see that output 0 and 1 consume significantly more power compared to the two others.

The vibration is not too bad, there is some vibrations, but shouldn’t be significant enough to affect the flying.
The yaw issue most likely comes from the different power to the motors, so it should be fixed, if you fix the motors.