Ubuntu users: How do you even launch QGC?

#1

I followed the instructions here.It asked me to enter the following commands:

chmod +x ./QGroundControl.AppImage
./QGroundControl.AppImage

I got this error:

QGC did start but I couldn’t connect to my Pixhawk. So I took it’s advice and entered the commands:

sudo usermod -a -G dialout $USER
sudo apt-get remove modemmanager

I closed QGC and tried to restart it but it no longer works. Nothing happens every time I go to the download directory and execute the AppImage by typing in ./QGroundControl.AppImage. I also tried to right click the app image and click on run. Nothing happens.

Any help?

P.S. I am using Ubuntu 18.04 LTS

UPDATE: Don’t know why or how but disconnecting everything and rebooting made it work again. Neither Ubuntu, nor the GQC installation guide ever mentions that a reboot is required. I hope this post will help anyone else who is going through similar problems.

#2

This is not related to QGC, it is a user permission problem.

sudo chmod 666 QGroundControl.AppImage
#3

usermod does not require reboot - but the new group membership is not active before login/logout.
or - you could use “su - $USER” - to apply have it right away.

I suspect, maybe, that there were something odd after the permission/modemmanager message, possible that the process never quit.

#4

After the usermod command, to join the dialout group (which allows access to the serial/usb port (s)), you need to logout and back in again for it to take effect. This also would happen as a result of a reboot.

#5

I am new to this system so as a general rule I am trying to get by by rebooting whenever in doubt :stuck_out_tongue:

#6

@DonLakeFlyer Is this message/check new? I have never had it, possibly because I always (?) install QGC as part of setting up dev environment, and that includes these changes.

Can you confirm whether it is always run, and hence whether we need to add instructions to the installation guide.