QGC AppImage not installing- running RPi4

Hi ,

I can not get QGroundControl.AppImage to install on RPi4/ Linux,
despite trying latest RaspberyPi OS, latest Ubuntu, Libfuse2, gstreamer,
etc as per docs.PX4 instructions. It says “executable”& “binary” -but
does not open/execute in any way.

Much appreciated,


PS: Permissions are already set to owner- I even tried Anyone. Still not executing on screen.

As I know, QGroundControl.AppImage compile for x86, but RPi is ARM v8. You need cross-compile QGC from source code.

Thanks Artem.
These are for older RPi3 Buster.

1.Is there any for latest RPi4B Bullseye?
2. So much coding… is there a ready file somewhere for installation?
3. I would like to go back to Raspberry OS, and remove Ubuntu, (as I have lost touch screen magnification by two fingers after installing latest ubuntu.)?

Thanks so much,

I think the steps are same.

Really don’t know, I didn’t do this. But many people are wrote: “It’s imposible”, and only few one said “I did it!”

Raspberry OS isn’t worse than ubuntu. Your trouble isn’t in OS( or not only in OS).

Good luck!