Triggering pointgrey camera using pixhawk

#1

Hi All,
I am trying to trigger the pointgrey blackfly camera (BFLY-U3-05S2C-CS) using pixhawk so that I can use the imu and the camera for state estimation. I have set the following parameters in QgroundControl:
TRIG_MODE: Time based, on command
TRIG_INTERFACE: GPIO
TRIG_INTERVAL: 50ms
TRIG_PINS: 56
TRIG_POLARITY: active low
TRIG_ACT_TIME: varied between 1ms to 40ms
I am using trigger mode0 and trig source gpio0 and connect the signal pin of AUX5 to the GPIO0 which is the input and ground of AUX5 to the ground of the camera. The camera is connected to the computer using its USB cable. if I do not connect the camera and measure the output at the pins I see 3.4V. If I just use the camera test of QgroundControl and see the output at Oscilloscope, I see the pulse. If I launch px4.launch file and trigger camera using that, I see pulses at regular intervals. However, when I connect the camera, it doesnt trigger. The voltage drops to 1.7V if that is the issue. I tried both AUX5 and AUX6 ports but no luck.

Can anyone please let me know if I am doing anything wrong.

Thanks,
Indrajeet

#2

The input gpio pin seems to go to an optocoupler. In the technical guide it mentions that you need to connect your ground to the OPTO_GND pin (pin 5) and not the GND (pin 6). This is because the ground of the camera and the ground of the pixhawk will remain separate. Is this your current setup?

#3

Hi Daniele,
Thank you for the reply. I was connecting the ground from pixhawk to OPTO_GND of the camera but I dont have the octocoupler currently in the setup. searching a little more over internet, I have order this 3V/3.3V relay with octocoupler trigger.


I hope it works. I will let you know once I receive and test it.

Thanks,
Indrajeet

#4

The optocoupler seems to be inside the camera… I don’t think you need an external one

#5

oh but then my setup is actually correct. I am using OPTO_IN (2) and OPTO_GND (5) to attach to the ground and signal pins of pixhawk but camera doesn’t trigger.

#6

Sorry I meant connecting camera’s (2) to the signal and (5) to the ground. Am I supposed to change any other setting in Pixhawk.

#7

Hi

We’re you able to solve this issue… I am facing the same issue

Thanks
Saurabh

#8

yah by changing the Pixhawk. I used the Pixhawk-4 (https://www.getfpv.com/pixhawk-4-autopilot.html) and exact same settings worked without any problem. I talked to holybro about this but got no reply. Even with pixhawk-4 voltage drops to 2.4V but it was sufficient to trigger the camera. I am not sure if something else was messed up in my pix32 but it worked fine otherwise.