Telemetry Radio Connection Issues

I’m having issues getting my telemetry radios to communicate. I’m using them to pass data from a microcontroller (Not a pixhawk or other flight controller, just a serial connection) to my desktop for a project I’m working on. Oddly enough, I had them working fine until a few nights ago when they stopped connecting to each other. I did not update my computer or the firmware of the radios when they stopped working. I got them cheap from Banggood

For diagnostic purposes …

  • The green light blinks on each of them, but doesn’t turn solid to indicate a good connection
  • I can ‘send’ data from both ends, but it is not received (The red light on each of them blinks when I send serial data, but it is not received in either direction)
  • I tried updating the firmware for each. I downloaded MP, went to SiK Radio Settings, hit ‘Load Settings’ and observed the settings already on the radio, then reuploaded the firmware to each successfully (solid red light while uploading plus ‘Done’ confirmation once finished). I made sure that the settings were identical for each firmware update.
  • I tried updating, disabling, and enabling the CP2102 drivers for the device with a few computer restarts (although I don’t think it’s a driver issue)

Any ideas? Any suggestions are greatly appreciated :slight_smile: