Slow qgroundcontrol interface on MacOS

Hello,

I’ve installed the latest version of qgroundcontrol (4.2.3) on my Intel-based Mac with OS version 12.6; the interface is so slow that the software cannot be used. As an example, the menu appears 10 to 15 seconds after clicking on the app logo.

I’ve tried also previous releases but the problem is always there; I tried also to install on the Mac (arm-based, OS 12) of a colleague and it worked, so it doesn’t seems to be a OS-related issue. I didn’t find similar problems looking on the internet, so I assume it is a problem related to my machine.

How can I solve this problem? I appreciate any help; many thanks.

Nicolò

@donlakeflyer maybe you’re the right person to solve the issue :slight_smile:

4.2.3 isn’t working correctly on the latest PR of MacOS (arm based) for me either. It launches and sits unusable as shown in the screenshot and is non-responsive.

Did you have the same problem with previous versions? Moreover, which is your OS version (maybe it’s a problem related to macOS 12.6)?

MacOS was a clean install on the previous OS version then updated to 12.6. Problem persisted on both versions with QGC 4.2.3 and I even tried 4.2.2 to compare. Same issue. Seems to hang right after location permissions are requested. Permissions are granted in MacOS but QGC asks again during every application start.

Clicking the application menu icon does nothing unless the space bar is pressed. The menu presents but is not functional. Subsequent attempts results in QGC not responding to anything else.

I just installed the latest daily build and it seems to be working fine. Something changed between 4.2.3 and today’s build.

Screen Shot 2022-09-23 at 9.04.36 AM

I run 4.2.3 on MacOS 10.15.7 on a Intel Macbook Pro and there it works. Also the builds from github on the masterbranch work.