Slow qgroundcontrol interface on MacOS

Hello,

I’ve installed the latest version of qgroundcontrol (4.2.3) on my Intel-based Mac with OS version 12.6; the interface is so slow that the software cannot be used. As an example, the menu appears 10 to 15 seconds after clicking on the app logo.

I’ve tried also previous releases but the problem is always there; I tried also to install on the Mac (arm-based, OS 12) of a colleague and it worked, so it doesn’t seems to be a OS-related issue. I didn’t find similar problems looking on the internet, so I assume it is a problem related to my machine.

How can I solve this problem? I appreciate any help; many thanks.

Nicolò

@donlakeflyer maybe you’re the right person to solve the issue :slight_smile:

4.2.3 isn’t working correctly on the latest PR of MacOS (arm based) for me either. It launches and sits unusable as shown in the screenshot and is non-responsive.

Did you have the same problem with previous versions? Moreover, which is your OS version (maybe it’s a problem related to macOS 12.6)?

MacOS was a clean install on the previous OS version then updated to 12.6. Problem persisted on both versions with QGC 4.2.3 and I even tried 4.2.2 to compare. Same issue. Seems to hang right after location permissions are requested. Permissions are granted in MacOS but QGC asks again during every application start.

Clicking the application menu icon does nothing unless the space bar is pressed. The menu presents but is not functional. Subsequent attempts results in QGC not responding to anything else.

I just installed the latest daily build and it seems to be working fine. Something changed between 4.2.3 and today’s build.

Screen Shot 2022-09-23 at 9.04.36 AM

I run 4.2.3 on MacOS 10.15.7 on a Intel Macbook Pro and there it works. Also the builds from github on the masterbranch work.

I tried the same daily build but it shows the same problem; I’ve solved installing V 4.1.7, it works fine.

I hope the problem will be solved in the next release of QGC.


I tried master on a Macbook Air (M1, 2020) running MacOS 12.5.1 (macOS Monterey) and that worked.

QGC on Mac is just not stable. I updated to the latest security update Apple pushed yesterday and we’re back to freezing on start.

QGC for Mac is still not working with Apple silicon on Ventura 13.0.1. QGC opens and freezes. What information does the community need to resolve this? What can I provide to help?

I’m observing same problem on macOS 12.5 and intel iCore5 - very slow gui response (30 sec on home icon). Seems to me problem is with ZeroConf. To fix it, go to config file, in my case it is:

~/.config/org.qgroundcontrol/QGroundControl\ Daily.ini

And add next section:

[LinkManager]
autoConnectZeroConf=false

I’ll check that out for next time. I solved the problem by wiping my Mac with another fresh install of MacOS. Hopefully this QGC install lasts longer than the last one.

I’ve tried this with the latest QGC 4.2.4 version but in my case the gui is still very slow (working with macOS 13.0.1).
I’m still using QGC 4.1.7 and it is fine.

Hi, I’ve an update on the situation with QGC: I needed some features available only in the 4.2.x version, so I tried again the solution proposed by @Vasyl_Maks here.

This time I removed all the files in ~/.config/org.qgroundcontrol related to the old QGC version. A new QGroundControl.ini file is created after the first launch of the app (which presented the initial slow GUI); as suggested I added

[LinkManager]
autoConnectZeroConf=false

and now QGC works without problems. Thanks @Vasyl_Maks for the hint; I moved the solution badge to match this.